Bug 1286173 - DHT : on lookup getting error ' cannot read symbolic link <dir1>: Invalid argument' or 'Input/output error' and logs says "[posix.c:737:posix_readlink] 0-flat-posix: readlink on <dir> failed Invalid argument" + it shows directory twice in output
DHT : on lookup getting error ' cannot read symbolic link <dir1>: Invalid arg...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Nithya Balachandran
storage-qa-internal@redhat.com
dht-retest, dht-rename-dir, dht-direc...
: ZStream
Depends On: 1034148
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 07:14 EST by Susant Kumar Palai
Modified: 2016-09-15 03:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1034148
Environment:
Last Closed: 2016-09-15 03:12:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Nithya Balachandran 2016-09-15 03:12:20 EDT
The rebalance crashes were fixed in earlier releases and there have been a lot of changes to both the rebalance and lookup code over the last few releases. 


I am closing this BZ as WontFix. If the issue is reproducible with the latest release, please open a new BZ.

Note You need to log in before you can comment on or make changes to this bug.