Bug 128619 - kppp fails since pppd now writes resolv.conf in /var/run/ppp
kppp fails since pppd now writes resolv.conf in /var/run/ppp
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
2
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-27 05:40 EDT by Malcolm Lee
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 06:16:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Malcolm Lee 2004-07-27 05:40:53 EDT
Description of problem:
kppp fails since pppd  now writes resolv.conf in /var/run/ppp whereas
kppp is still looking for it in /etc/ppp

Version-Release number of selected component (if applicable):
ppp-2.4.2-2   kdenetwork-3.2.2-1

How reproducible: Consistently (every time)


Steps to Reproduce:
1. Remove any old versions of /etc/ppp/resolv.conf
2. Use kppp to connect to an ISP using DNS setting of automatic
3.
  
Actual results:
/etc/resolv.conf is unchanged after connection since kppp is looking
for the ISP DNS addresses in /etc/ppp/resolv.conf whereas pppd has
written them into /var/run/ppp/resolv.conf. As a result no internet
addresses can be resolved and hence no connections of any sort can be
made.

Expected results:
/etc/resolv.conf is normally updated by kppp (for the duration of
connection) with the ISP DNS addresses eg

search xxxxx.yyy
nameserver 127.0.0.1
nameserver a.b.c.d        #kppp temp entry
nameserver w.x.y.z   #kppp temp entry



Additional info:
A simple workround is obviously to symbolic link /etc/ppp/resolv.conf
to /var/run/ppp/resolv.conf but it would obviously be better if pppd
and kppp both agreed on the location of the "temporary" resolv.conf file.
Comment 1 Ngo Than 2004-07-28 06:16:39 EDT
it's a know bug, which is already fixed in kde-3.2.3 or newer in rawhide.

Note You need to log in before you can comment on or make changes to this bug.