Bug 1286220 - batik: TIFF support is not working
batik: TIFF support is not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: batik (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Simacek
Fedora Extras Quality Assurance
:
: 976384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 08:32 EST by Mikolaj Izdebski
Modified: 2015-12-22 17:06 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.8-5 batik-1.8-5.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 17:06:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2015-11-27 08:32:44 EST
Description of problem:
Batik rasterizer cannot output TIFF images.

Version-Release number of selected component (if applicable):
batik-rasterizer-1.8-3.fc23.noarch

Steps to Reproduce:
rasterizer -m image/tiff image.svg

Actual results:
About to transcode 1 SVG file(s)

Converting image.svg to image.tif ... org.apache.batik.transcoder.TranscoderException: null
Enclosed Exception:
Could not write TIFF file because no WriteAdapter is availble
	at org.apache.batik.transcoder.image.ImageTranscoder.transcode(ImageTranscoder.java:132)
	at org.apache.batik.transcoder.XMLAbstractTranscoder.transcode(XMLAbstractTranscoder.java:142)
	at org.apache.batik.transcoder.SVGAbstractTranscoder.transcode(SVGAbstractTranscoder.java:156)
	at org.apache.batik.apps.rasterizer.SVGConverter.transcode(SVGConverter.java:1001)
	at org.apache.batik.apps.rasterizer.SVGConverter.execute(SVGConverter.java:717)
	at org.apache.batik.apps.rasterizer.Main.execute(Main.java:938)
	at org.apache.batik.apps.rasterizer.Main.main(Main.java:992)
... error (SVGConverter.error.while.rasterizing.file)
Comment 1 Mikolaj Izdebski 2015-11-27 10:51:11 EST
What about other batik apps? Eg. run squiggle, open SVG and try to export it as TIFF - it creates zero-sized file.
Comment 2 Michael Simacek 2015-11-30 05:22:57 EST
I didn't know squiggle can export raster images, sorry. I'll add it to all scripts to be sure.
Comment 3 Michael Simacek 2015-12-03 09:46:48 EST
*** Bug 976384 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2015-12-04 06:29:33 EST
batik-1.8-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4ee96847a9
Comment 5 Fedora Update System 2015-12-04 11:51:03 EST
batik-1.8-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update batik'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4ee96847a9
Comment 6 Fedora Update System 2015-12-22 17:06:14 EST
batik-1.8-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.