Bug 128623 - day of month inconsistency with English man-pages
day of month inconsistency with English man-pages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man-pages-ja (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Alexandre Petit-Bianco
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-27 06:49 EDT by Nakai
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 20040715-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 23:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nakai 2004-07-27 06:49:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6) Gecko/20040510

Description of problem:
English man page crontab(5) is saying day of month is 1-31,
but Japanese man page is saying 0-31.

This doesn't seem to be a upstream bug but 
a distro specific fix, so patch it
as Fedora specific.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. LANG=ja_JP.UTF-8 man 5 crontab
2. LANG=en_US man 5 crontab
3. day of month is different.
    

Actual Results:  day of month 0-31

Expected Results:  day of month 1-31

Additional info:

- This bug is translation related, but packaging issue.
- Other translated manuals also have same problem. At least,
  Korean man pages has.

  % LANG=ko_KR.UTF-8 man 5 crontab
  day of month is 0-31

- Iwai-san reported this bug.
Comment 2 Akira TAGOH 2004-07-27 07:11:40 EDT
erm, this doesn't seem to be an upstream bug?? it looks like to me
this is an upstream bug since crontab.5 was translated from Vixie
cron's manpage, and we are using it. this problem should be fixed
anyway, though.

BTW has anyone sent that patch to upstream yet?
Comment 3 IWAI, Masaharu 2004-07-27 22:49:36 EDT
English man page crontab(5) is saying day of month is 1-31, because 
it is patched up this bug by a distro specific fix patch.
OTOH this package's upstream - JM Project - translated from Vixie 
cron's manpage. 
Therefor I think JM Project should not fix this problem. 

> BTW has anyone sent that patch to upstream yet?

As far as I know anyone sent it to the JM Project.
Comment 4 Nakai 2004-07-27 23:08:39 EDT
This is a Fedora specific fix and upstream report doesn't make sense.
Such issue sometimes happen on man pages.

Fedora's vixie-cron-3.0.1-87.src.rpm has vixie-cron-3.0.1-0days.patch
and it's saying:

--- vixie-cron-3.0.1/crontab.5.0days    Fri Jul 30 16:48:52 1999
+++ vixie-cron-3.0.1/crontab.5  Fri Jul 30 16:50:18 1999
@@ -104,9 +104,9 @@
 .br
 hour   0-23
 .br
-day of month   0-31
+day of month   1-31
 .br
-month  0-12 (or names, see below)
+month  1-12 (or names, see below)
 .br
 day of week    0-7 (0 or 7 is Sun, or use names)
 .br
Comment 5 Akira TAGOH 2004-07-28 03:20:46 EDT
Comment #3:
Then even if it's not a mistranslation, how come you know this wrong
manpage issue and it's a reason why you don't contribute it to upstream?
they don't want to fix this until it's fixed by upstream? I guess not.
there is a cron which allows 0 as the day of month? I guess not. this
fix is useful for people who uses cron anyway. I don't see the reason
that this patch is applied for only us.

I'll contact upstream if you like. please let me know.
Comment 6 Akira TAGOH 2004-07-28 03:31:00 EDT
FYI: 0days patch is no longer applied to vixie-cron-4.1-1 in rawhide.
Comment 7 IWAI, Masaharu 2004-07-28 04:11:45 EDT
Comment #5:
To be sure, it is right. I will report it to this package's upstream.
Comment 8 Nakai 2004-07-28 05:06:39 EDT
Comment #5:
I don't agree to your guess because the line

day of week    0-7 (0 or 7 is Sun, or use names)

allows 0 and same to 7. So seems to be similar to day of month.
There are many UN*X variations in the world. Some are against our
Linux's common sense but insist they're correct. Some set most
broken Japanese IM by default but insist they are better than Novell.
Anyway, your communication with the upstream is great.

Comment #6:
Another manpage patch is in that rawhide package, one seems to be
fixed in the upstream but one is still not.
Comment 9 Akira TAGOH 2004-07-28 05:45:20 EDT
Comment #7:
Cool. Thanks :)
Comment 10 Akira TAGOH 2004-07-29 23:53:17 EDT
Fixed in 20040715-4 for rawhide and -3 for FC2 updates.

Note You need to log in before you can comment on or make changes to this bug.