Bug 1286233 - Fails to install on RHEL 7.2
Fails to install on RHEL 7.2
Status: NEW
Product: Fedora EPEL
Classification: Fedora
Component: weechat (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jamie Nguyen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 09:31 EST by Pierre-YvesChibon
Modified: 2016-09-04 00:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-YvesChibon 2015-11-27 09:31:54 EST
Hi,

Basically, weechat doesn't install on a brand new RHEL 7.2 (tried with epel-testing enabled to see, but no change).

$ sudo yum install weechat
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package weechat.x86_64 0:1.3-1.el7 will be installed
--> Processing Dependency: libguile-2.0.so.22(GUILE_2.0)(64bit) for package: weechat-1.3-1.el7.x86_64
--> Processing Dependency: libv8.so.3()(64bit) for package: weechat-1.3-1.el7.x86_64
--> Processing Dependency: libtcl8.5.so()(64bit) for package: weechat-1.3-1.el7.x86_64
--> Processing Dependency: libruby.so.2.0()(64bit) for package: weechat-1.3-1.el7.x86_64
--> Processing Dependency: libguile-2.0.so.22()(64bit) for package: weechat-1.3-1.el7.x86_64
--> Processing Dependency: libgc.so.1()(64bit) for package: weechat-1.3-1.el7.x86_64
--> Running transaction check
---> Package gc.x86_64 0:7.2d-7.el7 will be installed
---> Package ruby-libs.x86_64 0:2.0.0.598-25.el7_1 will be installed
---> Package tcl.x86_64 1:8.5.13-8.el7 will be installed
---> Package v8.x86_64 1:3.14.5.10-17.el7 will be installed
---> Package weechat.x86_64 0:1.3-1.el7 will be installed
--> Processing Dependency: libguile-2.0.so.22(GUILE_2.0)(64bit) for package: weechat-1.3-1.el7.x86_64
--> Processing Dependency: libguile-2.0.so.22()(64bit) for package: weechat-1.3-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: weechat-1.3-1.el7.x86_64 (epel)
           Requires: libguile-2.0.so.22()(64bit)
Error: Package: weechat-1.3-1.el7.x86_64 (epel)
           Requires: libguile-2.0.so.22(GUILE_2.0)(64bit)
Comment 1 Pierre-YvesChibon 2015-11-27 12:57:44 EST
Ok so the problem is that guile is in some of the server channels, but these aren't in the workstation so I had to recompile guile from the rawhide srpm: http://koji.fedoraproject.org/koji/taskinfo?taskID=11995634

$ python is_it_in_rhel.py guile --channel --release 7
guile is in RHEL 7;   version: 2.0.9;   archs: i686, ppc, ppc64, ppc64le, x86_64;   channels: rhel-7-for-power-optional-rpms, rhel-7-for-powerle-optional-rpms, rhel-7-server-optional-rpms
Comment 2 Jamie Nguyen 2015-11-30 02:50:23 EST
Hi! Thanks for the bug report.

It installs fine on CentOS 7, but I'm not sure how to resolve this for RH channels. Should I file a bug against component="guile" for product="Red Hat Enterprise Linux 7"?
Comment 3 deadrat 2016-07-07 03:09:24 EDT
I have installed weechat in CentOS 7.1.  
But now I am using RHEL 7.2. I updated RHEL 7.2 and then attempted to install it , but it failed. 

https://paste.fedoraproject.org/388553/
Comment 4 deadrat 2016-09-04 00:25:37 EDT
Installation of Weechat works on CentOS 7.2. But not in Red Hat Enterprise Linux Server release 7.2 (Maipo). 

https://da.gd/FaRvr

Note You need to log in before you can comment on or make changes to this bug.