Bug 1286248 - Confirmation message changes in real time during adding second subscription management application
Confirmation message changes in real time during adding second subscription m...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: Erik Nelson
Thom Carlin
: Triaged
Depends On:
Blocks: qci-sprint-17
  Show dependency treegraph
 
Reported: 2015-11-27 10:23 EST by Antonin Pagac
Modified: 2016-09-13 12:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:23:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2015-11-27 10:23:19 EST
Description of problem:
In subscription section of a deployment, the text in the message about successfully added Subscription management application changes when user tries to add another application. The text changes in real time as the user is typing letters.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20151118.t.0-RHCI-x86_64-dvd1.iso

How reproducible:
Always

Steps to Reproduce:
1. In a deployment, go to the subscription section, log in
2. Click on "New Subscription Management Application"
3. Create new application, submit
4. Click on "New Subscription Management Application" again
5. Type letters of the new application name into the name field. At the same time keep an eye on the underlying green message about successful add of the previous application.
6. What you are typing is appearing in the message, in the former place of  name of previously created subscription management application

Actual results:
Text in message about adding an application changes before submitting another application; it is changing while user is typing name of second application

Expected results:
Text on the message should not change while user is typing; it should change only when the second application is added successfully

Additional info:
Comment 1 Antonin Pagac 2016-01-15 06:51:47 EST
Reproduced. I created application with invalid characters:

"apagac-%ˇˇ+$$'>*\(/| added successfully."

tried to add another application, and the confirmation message is changing in real time, as I type the name of the new application.

RHCI-6.0-RHEL-7-20160114.t.0-RHCI-x86_64-dvd1.iso
Comment 2 Erik Nelson 2016-06-22 11:51:04 EDT
Fixed thanks to new modals.
Comment 3 Thom Carlin 2016-07-12 15:40:22 EDT
Verified in QCI-1.2-RHEL-7-20160711.t.1.  Was able to add 3 applications in a row without the name changing (until Submit was clicked)
Comment 9 errata-xmlrpc 2016-09-13 12:23:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.