Bug 1286249 - systemd-228-5.gite35a787.fc24 build failure on ppc64
systemd-228-5.gite35a787.fc24 build failure on ppc64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PPCTracker
  Show dependency treegraph
 
Reported: 2015-11-27 10:31 EST by Ngo Than
Modified: 2015-12-10 08:15 EST (History)
9 users (show)

See Also:
Fixed In Version: systemd-228-6.gite35a787
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 08:15:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ngo Than 2015-11-27 10:31:15 EST
systemd-228-1.fc24 build failure on ppc64make --no-print-directory

check-TESTS
SKIP: test-engine
PASS: test-cgroup-mask
PASS: test-job-type
PASS: test-env-replace
PASS: test-strbuf
PASS: test-strv
SKIP: test-path
PASS: test-path-util
PASS: test-strxcpyx
./build-aux/test-driver: line 107:  6719 Aborted                 (core dumped) "$@" > $log_file 2>&1
FAIL: test-siphash24
PASS: test-unit-name
PASS: test-unit-file
PASS: test-utf8

for more info please take a look at

http://ppc.koji.fedoraproject.org/kojifiles/work/tasks/9356/2939356/build.log
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-27 10:58:59 EST
Can you provide the backtrace? We know that there are various alignment issues in the siphash code, but the log output alone doesn't give much info.
Comment 2 Dan Horák 2015-11-27 11:13:19 EST
and because the ppc64le task almost finished (http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2939357), looks as an endianity bug
Comment 3 Peter Robinson 2015-11-27 14:47:47 EST
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2940408

In this one the ppc64le task did finish
Comment 4 Dan Horák 2015-11-27 15:58:07 EST
the latest version fails in different test, see runs under gdb below

[sharkcz@tyan-openpower-01 systemd-e35a7876b4ab1d53a7539a905613e31dc6ae50fd]$ gdb ./test-compress
GNU gdb (GDB) Fedora 7.10-29.fc23
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "ppc64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./test-compress...done.
(gdb) run
Starting program: /home/sharkcz/systemd/systemd-e35a7876b4ab1d53a7539a905613e31dc6ae50fd/test-compress 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
/* testing XZ text blob compression/decompression */
/* testing XZ random blob compression/decompression */
compression failed: No buffer space available
/* testing decompress_startswith with XZ on text text*/
/* testing decompress_startswith with XZ on random text*/
compression failed: No buffer space available
/* testing XZ compression */
/* create source from /home/sharkcz/systemd/systemd-e35a7876b4ab1d53a7539a905613e31dc6ae50fd/test-compress */
/* test compression */
XZ compression finished (175336 -> 38676 bytes, 22.1%)
Detaching after fork from child process 5243.
/* test decompression */
XZ decompression finished (38676 -> 175336 bytes, 453.3%)
Detaching after fork from child process 5246.
/* test faulty decompression */
Decompression failed: code 7
/* testing LZ4 text blob compression/decompression */
Assertion 'r == 0' failed at src/journal/test-compress.c:76, function test_compress_decompress(). Aborting.

Program received signal SIGABRT, Aborted.
0x00003fffb7d4f7f8 in __GI_raise (sig=<optimized out>) at ../sysdeps/unix/sysv/linux/raise.c:55
55	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Missing separate debuginfos, use: dnf debuginfo-install libgcc-5.1.1-4.fc23.ppc64
(gdb) where
#0  0x00003fffb7d4f7f8 in __GI_raise (sig=<optimized out>) at ../sysdeps/unix/sysv/linux/raise.c:55
#1  0x00003fffb7d51ac8 in __GI_abort () at abort.c:89
#2  0x0000000020002980 in log_assert_failed (text=<optimized out>, file=<optimized out>, line=<optimized out>, func=<optimized out>) at src/basic/log.c:783
#3  0x00000000200037b0 in test_compress_decompress (compression=<optimized out>, compress=<optimized out>, decompress=@0x200201a8: 0x20005ed0 <decompress_blob_lz4>, 
    data=0x3fffffffebe0 "text", data_len=116, may_fail=<optimized out>) at src/journal/test-compress.c:76
#4  0x000000002000236c in main (argc=<optimized out>, argv=0x3ffffffff2d8) at src/journal/test-compress.c:231
(gdb) quit



[sharkcz@tyan-openpower-01 systemd-e35a7876b4ab1d53a7539a905613e31dc6ae50fd]$ gdb ./test-compress-benchmark 
GNU gdb (GDB) Fedora 7.10-29.fc23
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "ppc64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./test-compress-benchmark...done.
(gdb) run
Starting program: /home/sharkcz/systemd/systemd-e35a7876b4ab1d53a7539a905613e31dc6ae50fd/test-compress-benchmark 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
XZ/zeros: compressed & decompressed 109208198 bytes in 2.00s (52.03MiB/s), mean compresion 99.96%, skipped 0 bytes
Assertion 'r == 0' failed at src/journal/test-compress-benchmark.c:130, function test_compress_decompress(). Aborting.

Program received signal SIGABRT, Aborted.
0x00003fffb7d4f7f8 in __GI_raise (sig=<optimized out>) at ../sysdeps/unix/sysv/linux/raise.c:55
55	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Missing separate debuginfos, use: dnf debuginfo-install libgcc-5.1.1-4.fc23.ppc64
(gdb) where
#0  0x00003fffb7d4f7f8 in __GI_raise (sig=<optimized out>) at ../sysdeps/unix/sysv/linux/raise.c:55
#1  0x00003fffb7d51ac8 in __GI_abort () at abort.c:89
#2  0x0000000020001dc8 in log_assert_failed (text=<optimized out>, file=<optimized out>, line=<optimized out>, func=<optimized out>) at src/basic/log.c:783
#3  0x0000000020002f24 in test_compress_decompress (label=0x20004378 "LZ4", type=0x20003ed8 "zeros", compress=@0x200200d0: 0x200023f4 <compress_blob_lz4>, 
    decompress=@0x200200b0: 0x20001e9c <decompress_blob_lz4>) at src/journal/test-compress-benchmark.c:130
#4  0x0000000020001ae4 in main (argc=<optimized out>, argv=<optimized out>) at src/journal/test-compress-benchmark.c:175
Comment 5 Zbigniew Jędrzejewski-Szmek 2015-11-27 17:30:14 EST
This program compresses and decompresses buffers of various size in a loop. So the backtrace is not very interesting, because it does not show in what iteration the loop was in. 'bt full' might possibly give more info.
Comment 6 Dan Horák 2015-11-27 17:49:56 EST
would this help?

(gdb) bt full
#0  0x00003fffb7d4f7f8 in __GI_raise (sig=<optimized out>) at ../sysdeps/unix/sysv/linux/raise.c:55
        r4 = 10711
        r7 = 70367533398752
        arg2 = 10711
        r5 = 6
        r8 = 0
        arg3 = 6
        r0 = 250
        r3 = 0
        r6 = 16384
        arg1 = 0
        sc_err = <optimized out>
        sc_ret = <optimized out>
        pd = 0x3fffb7ff59f0
        pid = 0
        selftid = 10711
#1  0x00003fffb7d51ac8 in __GI_abort () at abort.c:89
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x3fffffffe800, sa_sigaction = 0x3fffffffe800}, sa_mask = {__val = {0, 18446744069414584320, 0, 0, 537035328, 0, 
              0, 0, 0, 0, 37500353506544106, 70368744171424, 5697719214917784896, 70367532374212, 537004088, 107}}, sa_flags = 0, sa_restorer = 0x1}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x0000000020002980 in log_assert_failed (text=<optimized out>, file=<optimized out>, line=<optimized out>, func=<optimized out>) at src/basic/log.c:783
No locals.
#3  0x00000000200037b0 in test_compress_decompress (compression=<optimized out>, compress=<optimized out>, decompress=@0x200201a8: 0x20005ed0 <decompress_blob_lz4>, 
    data=0x3fffffffebe0 "text", data_len=116, may_fail=<optimized out>) at src/journal/test-compress.c:76
        compressed = "t\000\000\000\000\000\000\000\205text\000foo\003\000t AAAA a\001\000\365\020 ghost busters barbarbar FFFfoo\003\000\017\067\000\024P FFF", '\000' <repeats 17 times>, "?\377\377\377\352\330\000\000?\377\377\377\353\000\000\000?\377\377\377\352H\000\000\000\000\000\000\000\003\000\000\000\000\000\000\000\005\000\000?\377\377\377\365\235\000\000\000\000 \002\001X\000\000\000\000\000\000\000\004\000\000?\377\377\377\353p$\000\btXނ\241\000\000\000\000 \000=\374i2\252\310\034\034%\357'\375n\206\346\333ܸ\000\000\000\000 \002\202@\345\206"...
        csize = 74
        usize = 0
        decompressed = 0x0
        r = <optimized out>
        __func__ = "test_compress_decompress"
        __PRETTY_FUNCTION__ = "test_compress_decompress"
#4  0x000000002000236c in main (argc=<optimized out>, argv=0x3ffffffff2d8) at src/journal/test-compress.c:231
        text = "text\000foofoofoofoo AAAA aaaaaaaaa ghost busters barbarbar FFFfoofoofoofoo AAAA aaaaaaaaa ghost busters barbarbar FFF"
        data = "random\000\035\300\375z\264U3\350.`\000\224\367\345\234t9H\006\327\020\343Q]x\325\330-\b\030\222\024\245\221\t8`l\227W\206Ţä\026YH\222\250\225!A\246\206\000f\352\366\200'\336\060q\000\233B\363\017Y\346 \356̃[S<\332\327h2\032I~kf)Q\aL\245^\207l  \233\313\017F\350[pp\214L\371G\215Xނ\241V\302\322\t\324\020\252\213i2\252\310\034\034%\357'\375n\206\346\333ܸ\227\210\223Fj\262S\251\345\206N\320v\344\241R\206T\336^\ro\227\001\026\347̶\270X\306U\307\037[\332\333\177\332gC\vdB\231Lx\320+U\276e\224k\327\017]\364,ٌ\257"...
Comment 7 Zbigniew Jędrzejewski-Szmek 2015-12-02 00:07:37 EST
https://github.com/systemd/systemd/pull/2083
Comment 8 Dan Horák 2015-12-10 04:09:40 EST
Hi, can we get the fixes applied in the rawhide package? The lack of systemd 228 blocks work on rawhide in Fedora/ppc.

Note You need to log in before you can comment on or make changes to this bug.