Bug 1286293 - Fedora 23 x86_64bit :: "ideapad_laptop" driver on Lenovo Y700-17isk laptop hard blocks bluetooth and wlan radios ...
Fedora 23 x86_64bit :: "ideapad_laptop" driver on Lenovo Y700-17isk laptop ha...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 15:23 EST by prismalytics
Modified: 2015-12-22 17:02 EST (History)
9 users (show)

See Also:
Fixed In Version: kernel-4.2.8-200.fc22 kernel-4.2.8-300.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 02:21:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode output (run as root) ... (15.67 KB, text/plain)
2015-12-05 17:25 EST, prismalytics
no flags Details
dmesg output (run as root after a fresh boot) ... (68.88 KB, text/plain)
2015-12-05 17:26 EST, prismalytics
no flags Details
DMIDECODE Ideapad Y700 - 15ISK (15.67 KB, text/plain)
2015-12-16 18:13 EST, MohitK
no flags Details
DMESG Ideapad Y700 - 15ISK (97.75 KB, text/plain)
2015-12-16 18:14 EST, MohitK
no flags Details

  None (edit)
Description prismalytics 2015-11-27 15:23:55 EST
Hell friends:

I ran into this with my older Lenovo Yoga.Pro.2 13.3" laptop, but which has since been fixed.

The Lenovo laptop in question this time is the Lenovo Y700-17ISK (new very model available from Lenovo and also on Amazon  http://www.amazon.com/gp/product/B014MIC1EI).

Sadly, the only way to unblock the hard-blocked BLUETOOTH and WLAN radios is to issue the 'blacklist ideapad_laptop' directive in '/etc/modprobe.d/blacklist_ideapad_laptop.conf'. But unfortunately that disables handy keyboard driven functionality (volume up/down; brightness up/down; airplane on/off; and so on).

user@y700$ rfkill list; lsmod | grep ideapad
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
4: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
5: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
6: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: yes
[ ... ]
ideapad_laptop         24576  0
sparse_keymap          16384  1 ideapad_laptop
rfkill                 24576  3 cfg80211,ideapad_laptop,bluetooth
video                  36864  2 i915,ideapad_laptop

Is this a new bug or pilot error on my part?

Please and Thank You for the help! =:)
Comment 1 John W. Linville 2015-12-04 12:50:55 EST
This would seem to be a problem with the ideapad_laptop platform driver...
Comment 2 Josh Boyer 2015-12-04 13:45:18 EST
Can you please provide the output of dmidecode from this machine, as well as the output from dmesg from a fresh boot?
Comment 3 prismalytics 2015-12-05 17:25 EST
Created attachment 1102624 [details]
dmidecode output (run as root) ...
Comment 4 prismalytics 2015-12-05 17:26 EST
Created attachment 1102625 [details]
dmesg output (run as root after a fresh boot) ...
Comment 5 prismalytics 2015-12-05 17:28:38 EST
Hi Josh / John:

I attached the outputs requested in "comment #2".

Thank you for following up. =:)

Noel
Comment 6 Josh Boyer 2015-12-07 14:01:49 EST
I've started a scratch build with a potential patch.  When this completes, could you please test it and let us know if it fixes the issue?

http://koji.fedoraproject.org/koji/taskinfo?taskID=12101870
Comment 7 Josh Boyer 2015-12-07 15:25:03 EST
The scratch build failed for unrelated reasons.  I will do a local build and upload the results when it completes.
Comment 8 Josh Boyer 2015-12-07 16:58:55 EST
https://jwboyer.fedorapeople.org/pub/bz1286293/ Please test this kernel.
Comment 9 prismalytics 2015-12-07 18:30:27 EST
Hi again Josh:

See below. dnf(1) and rpm(1) complain that the kernel I already have installed is "newer" than the one you pointed me to, and will not install it. I prefer not to use "--nodeps" or things like that because that might overwrite something (make things unstable). =:)

Any way to integrate what you're trying into a newer kernel (one that I don't yet have installed)? See below and thanks.

Noel


user$ sudo dnf install *4.2.6*
[ ... snip ... ]   
Last metadata expiration check performed 0:00:00 ago on Mon Dec  7 18:19:44 2015.
Error: package kernel-modules-extra-4.2.6-301.bz1286293.fc23.x86_64 is not installable.
package kernel-modules-4.2.6-301.bz1286293.fc23.x86_64 is not installable.
package kernel-core-4.2.6-301.bz1286293.fc23.x86_64 is not installable.
package kernel-4.2.6-301.bz1286293.fc23.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)


user$ sudo rpm -Uvh *4.2.6*
Preparing...                          ################################# [100%]
	package kernel-core-4.2.6-301.fc23.x86_64 (which is newer than kernel-core-4.2.6-301.bz1286293.fc23.x86_64) is already installed
	package kernel-core-4.4.0-0.rc3.git4.1.fc24.x86_64 (which is newer than kernel-core-4.2.6-301.bz1286293.fc23.x86_64) is already installed
	package kernel-modules-4.2.6-301.fc23.x86_64 (which is newer than kernel-modules-4.2.6-301.bz1286293.fc23.x86_64) is already installed
	package kernel-modules-4.4.0-0.rc3.git4.1.fc24.x86_64 (which is newer than kernel-modules-4.2.6-301.bz1286293.fc23.x86_64) is already installed
	package kernel-4.2.6-301.fc23.x86_64 (which is newer than kernel-4.2.6-301.bz1286293.fc23.x86_64) is already installed
	package kernel-4.4.0-0.rc3.git4.1.fc24.x86_64 (which is newer than kernel-4.2.6-301.bz1286293.fc23.x86_64) is already installed
	package kernel-modules-extra-4.2.6-301.fc23.x86_64 (which is newer than kernel-modules-extra-4.2.6-301.bz1286293.fc23.x86_64) is already installed
	package kernel-modules-extra-4.4.0-0.rc3.git4.1.fc24.x86_64 (which is newer than kernel-modules-extra-4.2.6-301.bz1286293.fc23.x86_64) is already installed
Comment 10 Josh Boyer 2015-12-07 19:20:16 EST
You have a rawhide kernel installed.  I can build a version of that with the potential patch included, but I started with f23 since that is what you reported the bug against.  It will take some time.
Comment 11 prismalytics 2015-12-07 22:22:24 EST
Ah, okay.

Yes I'm temporarily running a RAWHIDE kernel (4.4.0-0.rc3.git4.1.fc24.x86_64) because of another possible bug that I recently opened related to this same laptop (related to Bumblebee video and dual Intel and nVidia/Optimus cards):

    https://bugzilla.redhat.com/show_bug.cgi?id=1288783

So indeed I have that RAWHIDE kernel, as well as regular released kernels to boot to.

Maybe you can integrate your proposed changes into RAWHIDE by updating the v4.4.0-0.rc3.git4.1.fc24.x86_64 line, and then I'll remove that RAWHIDE version and install your updated RAWHIDE one?

Just a thought. Whatever you do, it's always appreciated, so thank you!

Noel
Comment 12 Josh Boyer 2015-12-08 07:49:46 EST
OK, there is a newer kernel at the same URL as above.  Please test.
Comment 13 Josh Boyer 2015-12-09 09:28:20 EST
(In reply to Josh Boyer from comment #12)
> OK, there is a newer kernel at the same URL as above.  Please test.

Did this work to unblock the wifi?
Comment 14 prismalytics 2015-12-09 11:12:58 EST
Hi Josh:

I didn't get a chance to try it last night (NYC time).

I will give it a try tonight and let you know how I made out.

===============================
Under a separate cover,...
===============================
Someone (perhaps you Josh?) mentioned in another bug (that I filed) that the "SkyLake" architecture will eventually be supported in some future kernel. Currently it appears to be supported in the above RAWHIDE kernel. (This laptop employs that architecture).

Do you happen to know (roughly) when that support may appear?
REASON: When that support is released I'll have a little easier time asking nVidia to get their driver
to compile against it (currently it doesn't complete successfully in this RAWHIDE kernel, which supports
SkyLake).


Either way, I'll get back to you on this issue here.

Thanks again.
Comment 15 Josh Boyer 2015-12-09 11:33:09 EST
I believe initial Skylake support landed in the 4.3 kernel.  The Fedora release branches will get 4.3 most likely the first week of January.  As you've found, rawhide already contains whatever support is needed.
Comment 16 prismalytics 2015-12-09 19:38:22 EST
Hi Josh:

I can confirm that your changes to ideapad_laptop fixes the issue. Not only is the below now correct, but the keyboard functions work as
expected, too (e.g. volume up/down; brightness up/down; airplane mode; as
well as the XFCE PowerManager applet's brightness slider... that responds
correctly as well).

I guess this will be incorporated into some upcoming kernel?

See below, and thank you again! Nice work! :)

Noel

user$ lsmod | grep idea
ideapad_laptop         24576  0
sparse_keymap          16384  1 ideapad_laptop
rfkill                 24576  5 cfg80211,ideapad_laptop,bluetooth
wmi                    20480  1 ideapad_laptop
video                  40960  2 i915,ideapad_laptop

user$ rfkill list
0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
Comment 17 Josh Boyer 2015-12-10 08:30:28 EST
Thanks for testing.  I've committed the change on all Fedora branches.  The Fedora updates system will leave messages here when it is available.
Comment 18 MohitK 2015-12-16 18:12:21 EST
I've a similar laptop which is Ideapad Y700 15 inch - 15ISK model. The one you fixed is 17inch.
I'm attaching dmidecode and dmesg too.
Comment 19 MohitK 2015-12-16 18:13 EST
Created attachment 1106544 [details]
DMIDECODE Ideapad Y700 - 15ISK
Comment 20 MohitK 2015-12-16 18:14 EST
Created attachment 1106545 [details]
DMESG Ideapad Y700 - 15ISK
Comment 21 Fedora Update System 2015-12-17 07:53:09 EST
kernel-4.2.8-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c59710b05d
Comment 22 Fedora Update System 2015-12-17 07:54:22 EST
kernel-4.2.8-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c1c2f5e168
Comment 23 Fedora Update System 2015-12-18 06:26:33 EST
kernel-4.2.8-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c1c2f5e168
Comment 24 Fedora Update System 2015-12-18 06:55:26 EST
kernel-4.2.8-300.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c59710b05d
Comment 25 Fedora Update System 2015-12-22 02:19:49 EST
kernel-4.2.8-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2015-12-22 17:01:01 EST
kernel-4.2.8-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.