Bug 1286325 - semanage permissive fails and reports valid domain types as "not a domain type"
semanage permissive fails and reports valid domain types as "not a domain type"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Lautrbach
Fedora Extras Quality Assurance
:
: 1291604 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 23:05 EST by sorasl
Modified: 2015-12-16 09:35 EST (History)
4 users (show)

See Also:
Fixed In Version: policycoreutils-2.4-18.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 03:23:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sorasl 2015-11-27 23:05:11 EST
Description of problem:
Using semanage permissive does not make domains permissive but instead reports that the domain isn't a domain type

Version-Release number of selected component (if applicable):
policycoreutils-python-utils-2.4-17.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. semanage permissive -a httpd_t

Actual results:
ValueError: ['httpd_t'] is not a domain type

Expected results:
httpd_t is added as a permissive domain
Comment 1 Petr Lautrbach 2015-12-11 06:28:37 EST
Thanks for the report. It's already fixed in rawhide and the fix will be in the next f23 update.

https://github.com/fedora-selinux/selinux/commit/aa4f35f0b462af8bd0f02cf8d948ba2e824dd082
Comment 2 sorasl 2015-12-13 12:25:17 EST
Thanks for the fix. Appreciated.
Comment 3 Fedora Update System 2015-12-14 15:21:20 EST
policycoreutils-2.4-18.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c24c78c36d
Comment 4 Petr Lautrbach 2015-12-15 04:42:20 EST
*** Bug 1291604 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2015-12-15 05:52:22 EST
policycoreutils-2.4-18.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update policycoreutils'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c24c78c36d
Comment 6 Jamie Nguyen 2015-12-15 06:20:08 EST
I can confirm that "semanage permissive -a foo_t" works again with policycoreutils-2.4-18.fc23. Thanks!
Comment 7 Fedora Update System 2015-12-16 03:23:50 EST
policycoreutils-2.4-18.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-12-16 09:35:00 EST
policycoreutils-2.4-18.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.