Bug 1286376 - vmw_pvscsi stacktraces
vmw_pvscsi stacktraces
Status: CLOSED DUPLICATE of bug 926917
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-28 13:56 EST by Harald Reindl
Modified: 2015-12-01 11:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 11:36:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2015-11-28 13:56:56 EST
i wrote a similar bugreport years ago and also refered on the open-vm-tools mailing-list there and it looked like it was fixed, however, in current debug builds there are still errors/warnings which should *not* exist in a major hardware driver

Nov 28 19:42:15 rawhide kernel: VMware PVSCSI driver - version 1.0.5.0-k
Nov 28 19:42:15 rawhide kernel: vmw_pvscsi: using 64bit dma
Nov 28 19:42:15 rawhide kernel: vmw_pvscsi: max_id: 16
Nov 28 19:42:15 rawhide kernel: vmw_pvscsi: setting ring_pages to 8
Nov 28 19:42:15 rawhide kernel: vmw_pvscsi: using MSI-X
Nov 28 19:42:15 rawhide kernel: vmw_pvscsi: device does not support req_threshold
Nov 28 19:42:15 rawhide kernel: scsi host2: VMware PVSCSI storage adapter rev 2, req/cmp/msg rings: 8/8/1 pages, cmd_per_lun=254
Nov 28 19:42:15 rawhide kernel: vmw_pvscsi 0000:13:00.0: VMware PVSCSI rev 2 host #2
Nov 28 19:42:15 rawhide kernel: ------------[ cut here ]------------
Nov 28 19:42:15 rawhide kernel: WARNING: CPU: 0 PID: 166 at lib/dma-debug.c:1156 check_unmap+0x4bc/0x960()
Nov 28 19:42:15 rawhide kernel: vmw_pvscsi 0000:13:00.0: DMA-API: device driver failed to check map error[device address=0x000000001af9c180] [size=96 bytes] [mapped as single]
Nov 28 19:42:15 rawhide kernel: Modules linked in:
Nov 28 19:42:15 rawhide kernel: vmw_pvscsi
Nov 28 19:42:15 rawhide kernel: CPU: 0 PID: 166 Comm: systemd-udevd Not tainted 4.4.0-0.rc2.git2.1.fc24.x86_64 #1
Nov 28 19:42:15 rawhide kernel: Hardware name: VMware, Inc. VMware Virtual Platform/440BX Desktop Reference Platform, BIOS 6.00 07/02/2015
Nov 28 19:42:15 rawhide kernel: 0000000000000000 00000000677a9c89 ffff88001fa03be0 ffffffff81424e89
Nov 28 19:42:15 rawhide kernel: ffff88001fa03c28 ffff88001fa03c18 ffffffff810ab4b2 ffff88001d7a2bf0
Nov 28 19:42:15 rawhide kernel: ffff88001d234180 ffffffff834372d0 0000000000000086 ffffffff81ce43f9
Nov 28 19:42:15 rawhide kernel: Call Trace:
Nov 28 19:42:15 rawhide kernel: <IRQ>  [<ffffffff81424e89>] dump_stack+0x4b/0x72
Nov 28 19:42:15 rawhide kernel: [<ffffffff810ab4b2>] warn_slowpath_common+0x82/0xc0
Nov 28 19:42:15 rawhide kernel: [<ffffffff810ab54c>] warn_slowpath_fmt+0x5c/0x80
Nov 28 19:42:15 rawhide kernel: [<ffffffff81457dfc>] check_unmap+0x4bc/0x960
Nov 28 19:42:15 rawhide kernel: [<ffffffff81458319>] debug_dma_unmap_page+0x79/0xa0
Nov 28 19:42:15 rawhide kernel: [<ffffffffa000064a>] pvscsi_unmap_buffers.isra.12+0x11a/0x1d0 [vmw_pvscsi]
Nov 28 19:42:15 rawhide kernel: [<ffffffffa00007c5>] pvscsi_process_completion_ring+0xc5/0x280 [vmw_pvscsi]
Nov 28 19:42:15 rawhide kernel: [<ffffffffa0000bd3>] ? pvscsi_isr+0x23/0xa0 [vmw_pvscsi]
Nov 28 19:42:15 rawhide kernel: [<ffffffffa0000bde>] pvscsi_isr+0x2e/0xa0 [vmw_pvscsi]
Nov 28 19:42:15 rawhide kernel: [<ffffffff8111cd21>] handle_irq_event_percpu+0x41/0x300
Nov 28 19:42:15 rawhide kernel: [<ffffffff8111d019>] handle_irq_event+0x39/0x60
Nov 28 19:42:15 rawhide kernel: [<ffffffff81120564>] handle_edge_irq+0x74/0x130
Nov 28 19:42:15 rawhide kernel: [<ffffffff8101f193>] handle_irq+0x73/0x120
Nov 28 19:42:15 rawhide kernel: [<ffffffff8112b8a6>] ? rcu_irq_enter+0x86/0x90
Nov 28 19:42:15 rawhide kernel: [<ffffffff81876301>] do_IRQ+0x61/0x120
Nov 28 19:42:15 rawhide kernel: [<ffffffff818740cc>] common_interrupt+0x8c/0x8c
Nov 28 19:42:15 rawhide kernel: <EOI> 
Nov 28 19:42:15 rawhide kernel: ---[ end trace 0ba887b229be0e75 ]---
Nov 28 19:42:15 rawhide kernel: Mapped at:
Nov 28 19:42:15 rawhide kernel: [<ffffffff8145686b>] debug_dma_map_page+0x8b/0x150
Nov 28 19:42:15 rawhide kernel: [<ffffffffa0001291>] pvscsi_queue+0x1e1/0x7e0 [vmw_pvscsi]
Nov 28 19:42:15 rawhide kernel: [<ffffffff815bf18c>] scsi_dispatch_cmd+0x10c/0x360
Nov 28 19:42:15 rawhide kernel: [<ffffffff815c1ff9>] scsi_request_fn+0x479/0x620
Nov 28 19:42:15 rawhide kernel: [<ffffffff813eca33>] __blk_run_queue+0x33/0x40
Nov 28 19:42:15 rawhide kernel: scsi 2:0:0:0: Direct-Access     VMware,  VMware Virtual S 1.0  PQ: 0 ANSI: 2
Nov 28 19:42:15 rawhide kernel: scsi 2:0:1:0: Direct-Access     VMware,  VMware Virtual S 1.0  PQ: 0 ANSI: 2
Comment 1 Josh Boyer 2015-12-01 11:36:31 EST

*** This bug has been marked as a duplicate of bug 926917 ***

Note You need to log in before you can comment on or make changes to this bug.