This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286385 - https://www.youtube.com/watch?v=47g0Ed1eHaY causes youtube-dl to crash
https://www.youtube.com/watch?v=47g0Ed1eHaY causes youtube-dl to crash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: youtube-dl (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-28 15:51 EST by Peter H. Jones
Modified: 2015-12-06 17:47 EST (History)
2 users (show)

See Also:
Fixed In Version: youtube-dl-2015.11.27.1-1.fc23 youtube-dl-2015.11.27.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-05 20:21:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
typescript of failing session (6.90 KB, text/plain)
2015-11-28 15:51 EST, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2015-11-28 15:51:51 EST
Created attachment 1100000 [details]
typescript of failing session

Description of problem:
youtube-dl crashes with https://www.youtube.com/watch?v=47g0Ed1eHaY .

Version-Release number of selected component (if applicable):
youtube-dl-2015.11.21-1.fc22.noarch

How reproducible:
Every time.

Steps to Reproduce:
1. 'youtube-dl https://www.youtube.com/watch?v=47g0Ed1eHaY'

Actual results:
Crashes with diagnostic messages

Expected results:
Download video

Additional info:
The link works fine in Firefox. Adding a --verbose run as
an attachment.
Comment 1 Fedora Update System 2015-12-01 12:18:54 EST
youtube-dl-2015.11.27.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-e2db374b30
Comment 2 Fedora Update System 2015-12-01 12:18:55 EST
youtube-dl-2015.11.27.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-34b54d6f53
Comment 3 Peter H. Jones 2015-12-02 19:12:21 EST
Got a bit further, but then got an Unsouuported URL message:

"$ youtube-dl --verbose 'http://koji.fedoraproject.org/koji/buildinfo?buildID=702582'
[debug] System config: ['--prefer-free-formats']
[debug] User config: []
[debug] Command-line args: ['--verbose', 'http://koji.fedoraproject.org/koji/buildinfo?buildID=702582']
[debug] Encodings: locale UTF-8, fs utf-8, out UTF-8, pref UTF-8
[debug] youtube-dl version 2015.11.27.1
[debug] Python version 3.4.2 - Linux-4.2.6-201.fc22.x86_64-x86_64-with-fedora-22-Twenty_Two
[debug] exe versions: ffmpeg 2.6.4, ffprobe 2.6.4
[debug] Proxy map: {}
[generic] buildinfo?buildID=702582: Requesting header
^[[0;33mWARNING:^[[0m Falling back on generic information extractor.
[generic] buildinfo?buildID=702582: Downloading webpage
[generic] buildinfo?buildID=702582: Extracting information
^[[0;31mERROR:^[[0m Unsupported URL: http://koji.fedoraproject.org/koji/buildinfo?buildID=702582
Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/youtube_dl/YoutubeDL.py", line 663, in extract_info
    ie_result = ie.extract(url)
  File "/usr/lib/python3.4/site-packages/youtube_dl/extractor/common.py", line 290, in extract
    return self._real_extract(url)
  File "/usr/lib/python3.4/site-packages/youtube_dl/extractor/generic.py", line 1887, in _real_extract
    raise UnsupportedError(url)
youtube_dl.utils.UnsupportedError: Unsupported URL: http://koji.fedoraproject.org/koji/buildinfo?buildID=702582
"
Comment 4 Fedora Update System 2015-12-03 11:02:49 EST
youtube-dl-2015.11.27.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update youtube-dl'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-e2db374b30
Comment 5 Fedora Update System 2015-12-03 20:38:11 EST
youtube-dl-2015.11.27.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update youtube-dl'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-34b54d6f53
Comment 6 Peter H. Jones 2015-12-03 22:43:03 EST
Since I am able to play the original URL in Firefox, I right-clicked in the video to get its URL. That URL worked fine. In other words, addiing the parameter : "feature=player_detailpage" allows youtube-dl to download the video.

"youtube-dl 'https://www.youtube.com/watch?feature=player_detailpage&v=47g0Ed1eHaY'
[youtube] 47g0Ed1eHaY: Downloading webpage
[youtube] 47g0Ed1eHaY: Downloading video info webpage
[youtube] 47g0Ed1eHaY: Extracting video information
[youtube] 47g0Ed1eHaY: Downloading js player en_US-vfl_RJZIW
[youtube] 47g0Ed1eHaY: Downloading DASH manifest
[download] Destination: Baradero - Chacarera del rancho-47g0Ed1eHaY.f135.mp4
[download] 100% of 18.38MiB in 00:15
[download] Destination: Baradero - Chacarera del rancho-47g0Ed1eHaY.f141.m4a
[download] 100% of 4.91MiB in 00:04
[ffmpeg] Merging formats into "Baradero - Chacarera del rancho-47g0Ed1eHaY.mp4"
Deleting original file Baradero - Chacarera del rancho-47g0Ed1eHaY.f135.mp4 (pass -k to keep)
Deleting original file Baradero - Chacarera del rancho-47g0Ed1eHaY.f141.m4a (pass -k to keep)
"

So I tried the original link again, and was told, as expected the video was already downloaded. So I presume something may have changed on the youtube site, allowing the download to work. According, I recommend closing this bug report.
Comment 7 Fedora Update System 2015-12-05 20:21:36 EST
youtube-dl-2015.11.27.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Till Maas 2015-12-06 02:31:46 EST
(In reply to Peter H. Jones from comment #3)
> Got a bit further, but then got an Unsouuported URL message:
> 
> "$ youtube-dl --verbose
> 'http://koji.fedoraproject.org/koji/buildinfo?buildID=702582'

FYI: You tried to download a koji URL here.
Comment 9 Peter H. Jones 2015-12-06 08:26:08 EST
Re comment 8:
Oops! Sorry!

Enough said. Thanks.
Comment 10 Fedora Update System 2015-12-06 17:47:23 EST
youtube-dl-2015.11.27.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.