Bug 1286397 - Package should create and own /etc/systemd/network
Package should create and own /etc/systemd/network
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-28 19:07 EST by DaveG
Modified: 2015-12-10 08:22 EST (History)
7 users (show)

See Also:
Fixed In Version: systemd-228-6.gite35a787.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 08:22:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DaveG 2015-11-28 19:07:08 EST
Description of problem:

The systemd package does not include the directory /etc/systemd/network, the administrative configuration area for systemd-networkd.

Other package or automation scripts, Ansible etc. need an additional step to check for and create the directory if used, possibly leading to confusion over which package 'owns' the directory.

Version-Release number of selected component (if applicable):

systemd-219-25.fc22.x86_64


Additional info:

Just needs one more line in systemd.spec %files section:
%dir %{_sysconfdir}/systemd/network
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-28 22:09:11 EST
We didn't do that because systemd-networkd was never officially supported. But people are using it anyway, so I guess this does not matter anymore. I added the path in the spec file. Do you actually care about F22 or is rawhide enough?
Comment 2 DaveG 2015-11-28 22:36:02 EST
No particular need, just needs to be in place before other packages or spins start using the facility.

I can confirm that Fedora 22 can run without NetworkManager or initscripts networking, even with PPPoE.

Note You need to log in before you can comment on or make changes to this bug.