Bug 1286407 - ironic-api is spamming /var/log/messages
ironic-api is spamming /var/log/messages
Status: CLOSED DUPLICATE of bug 1246525
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity medium
: ---
: 7.0 (Kilo)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 01:33 EST by Amit Ugol
Modified: 2015-11-30 07:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 07:50:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Ugol 2015-11-29 01:33:31 EST
Description of problem:
/var/log/messages is being spammed with:


Nov 29 01:30:37 instack account-server: Beginning replication run
Nov 29 01:30:37 instack account-server: Replication run OVER
Nov 29 01:30:37 instack account-server: Attempted to replicate 1 dbs in 0.00323 seconds (309.12252/s)
Nov 29 01:30:37 instack account-server: Removed 0 dbs
Nov 29 01:30:37 instack account-server: 0 successes, 0 failures
Nov 29 01:30:37 instack account-server: no_change:0 ts_repl:0 diff:0 rsync:0 diff_capped:0 hashmatch:0 empty:0
Nov 29 01:30:37 instack ironic-api: 2015-11-29 01:30:37.044 26194 DEBUG keystonemiddleware.auth_token [-] Storing token in cache store /usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_cache.py:192
Nov 29 01:30:37 instack ironic-api: 2015-11-29 01:30:37.045 26194 DEBUG keystonemiddleware.auth_token [-] Authenticating service token __call__ /usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py:603
Nov 29 01:30:37 instack ironic-api: 2015-11-29 01:30:37.046 26194 DEBUG keystonemiddleware.auth_token [-] Received request from user: user_id af3b3297144b4762b4c3adefbbc9f160, project_id 92e6a40fab75448f97ddacfab01ca38d, roles _member_,admin service: user_id None, project_id None, roles None __call__ /usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py:632
Nov 29 01:30:37 instack ironic-api: 192.0.2.1 - - [29/Nov/2015 01:30:37] "GET /v1/ports HTTP/1.1" 200 869
Nov 29 01:30:37 instack ironic-api: 192.0.2.1 - - [29/Nov/2015 01:30:37] "GET / HTTP/1.0" 200 316
Nov 29 01:30:37 instack ironic-api: Traceback (most recent call last):
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/wsgiref/handlers.py", line 86, in run
Nov 29 01:30:37 instack ironic-api: self.finish_response()
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/wsgiref/handlers.py", line 128, in finish_response
Nov 29 01:30:37 instack ironic-api: self.write(data)
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/wsgiref/handlers.py", line 212, in write
Nov 29 01:30:37 instack ironic-api: self.send_headers()
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/wsgiref/handlers.py", line 270, in send_headers
Nov 29 01:30:37 instack ironic-api: self.send_preamble()
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/wsgiref/handlers.py", line 194, in send_preamble
Nov 29 01:30:37 instack ironic-api: 'Date: %s\r\n' % format_date_time(time.time())
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/socket.py", line 324, in write
Nov 29 01:30:37 instack ironic-api: self.flush()
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/socket.py", line 303, in flush
Nov 29 01:30:37 instack ironic-api: self._sock.sendall(view[write_offset:write_offset+buffer_size])
Nov 29 01:30:37 instack ironic-api: File "/usr/lib/python2.7/site-packages/eventlet/greenio/base.py", line 377, in sendall
Nov 29 01:30:37 instack ironic-api: tail = self.send(data, flags)
Nov 29 01:30:37 instack ironic-api: File "/usr/lib/python2.7/site-packages/eventlet/greenio/base.py", line 359, in send
Nov 29 01:30:37 instack ironic-api: total_sent += fd.send(data[total_sent:], flags)
Nov 29 01:30:37 instack ironic-api: error: [Errno 104] Connection reset by peer
Nov 29 01:30:37 instack ironic-api: 192.0.2.1 - - [29/Nov/2015 01:30:37] "GET / HTTP/1.0" 500 59
Nov 29 01:30:37 instack ironic-api: Traceback (most recent call last):
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/SocketServer.py", line 593, in process_request_thread
Nov 29 01:30:37 instack ironic-api: self.finish_request(request, client_address)
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/SocketServer.py", line 334, in finish_request
Nov 29 01:30:37 instack ironic-api: self.RequestHandlerClass(request, client_address, self)
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/SocketServer.py", line 651, in __init__
Nov 29 01:30:37 instack ironic-api: self.finish()
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/SocketServer.py", line 710, in finish
Nov 29 01:30:37 instack ironic-api: self.wfile.close()
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/socket.py", line 279, in close
Nov 29 01:30:37 instack ironic-api: self.flush()
Nov 29 01:30:37 instack ironic-api: File "/usr/lib64/python2.7/socket.py", line 303, in flush
Nov 29 01:30:37 instack ironic-api: self._sock.sendall(view[write_offset:write_offset+buffer_size])
Nov 29 01:30:37 instack ironic-api: File "/usr/lib/python2.7/site-packages/eventlet/greenio/base.py", line 377, in sendall
Nov 29 01:30:37 instack ironic-api: tail = self.send(data, flags)
Nov 29 01:30:37 instack ironic-api: File "/usr/lib/python2.7/site-packages/eventlet/greenio/base.py", line 359, in send
Nov 29 01:30:37 instack ironic-api: total_sent += fd.send(data[total_sent:], flags)
Nov 29 01:30:37 instack ironic-api: error: [Errno 32] Broken pipe



Version-Release number of selected component (if applicable):
openstack-ironic-api-2015.1.2-2.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install openstack

Actual results:
~300mb per day worth of spam in /var/log/messages

Expected results:
!Actual


Additional info:
Comment 1 James Slagle 2015-11-30 07:50:27 EST

*** This bug has been marked as a duplicate of bug 1246525 ***

Note You need to log in before you can comment on or make changes to this bug.