Bug 1286422 - RHEL-OSP director 7.2 puddle 'instack-install-undercloud' returned non-zero exit status 1'
RHEL-OSP director 7.2 puddle 'instack-install-undercloud' returned non-zero e...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 06:13 EST by Asaf Hirshberg
Modified: 2016-04-18 02:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-29 07:58:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asaf Hirshberg 2015-11-29 06:13:46 EST
Description of problem:
failing to install RHEL-OSP director 7.2 puddle. 
when using "openstack undercloud install" i get the following error:

Version-Release number of selected component (if applicable):

+ puppet apply --detailed-exitcodes /etc/puppet/manifests/puppet-stack-config.pp
Warning: You cannot collect without storeconfigs being set on line 235 in file /etc/puppet/manifests/puppet-stack-config.pp
Warning: You cannot collect without storeconfigs being set on line 239 in file /etc/puppet/manifests/puppet-stack-config.pp
Warning: You cannot collect without storeconfigs being set on line 243 in file /etc/puppet/manifests/puppet-stack-config.pp
Error: Could not find data item service_certificate in any Hiera data file and no default supplied at /etc/puppet/manifests/puppet-stack-config.pp:98 on node puma33.scl.lab.tlv.redhat.com
Error: Could not find data item service_certificate in any Hiera data file and no default supplied at /etc/puppet/manifests/puppet-stack-config.pp:98 on node puma33.scl.lab.tlv.redhat.com
+ rc=1
+ set -e
+ echo 'puppet apply exited with exit code 1'
puppet apply exited with exit code 1
+ '[' 1 '!=' 2 -a 1 '!=' 0 ']'
+ exit 1
[2015-11-29 11:31:30,433] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]

[2015-11-29 11:31:30,433] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 526, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 461, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 297, in _run_live_command
    raise RuntimeError('%s failed. See log for details.', name)
RuntimeError: ('%s failed. See log for details.', 'os-refresh-config')
ERROR: openstack Command 'instack-install-undercloud' returned non-zero exit status 1



How reproducible:
3/3

Steps to Reproduce:
sudo useradd stack
sudo passwd stack  # qum5net
echo "stack ALL=(root) NOPASSWD:ALL" | sudo tee -a /etc/sudoers.d/stack
sudo chmod 0440 /etc/sudoers.d/stack
su - stack
sudo hostnamectl set-hostname puma33.scl.lab.tlv.redhat.com
sudo hostnamectl set-hostname --transient puma33.scl.lab.tlv.redhat.com 
sudo echo "127.0.0.1 puma33.scl.lab.tlv.redhat.com">> /etc/hosts
sudo yum localinstall -y http://rhos-release.virt.bos.redhat.com/repos/rhos-release/rhos-release-latest.noarch.rpm
sudo rhos-release 7-director
sudo yum install -y python-rdomanager-oscplugin
cp /usr/share/instack-undercloud/undercloud.conf.sample ~/undercloud.conf # change the interface for enp5s0f1
openstack undercloud install

Actual results:
failed to install the undercloud

Expected results:
undercloud installed without any errors

Additional info:
hiera-3.0.1-1.el7.noarch
sos report:
scp root@10.35.65.14:/root/sosreport-asafhirshberg-20151129114225.tar.xz  root/12345678
Comment 2 Asaf Hirshberg 2015-11-29 07:13:01 EST
workaround: 
using "yum remove puppet hiera" before installing the undercloud "openstack undercloud install"
Comment 3 Asaf Hirshberg 2015-11-29 07:58:07 EST
close not a bug:

foreman provision of rhel 7.2 install epel by default.

Note You need to log in before you can comment on or make changes to this bug.