Bug 1286451 - Please update Chirp to support Baofeng BF-F8HP radios
Please update Chirp to support Baofeng BF-F8HP radios
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: chirp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Shaw
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 11:30 EST by Jaroslav Škarvada
Modified: 2015-12-14 06:52 EST (History)
2 users (show)

See Also:
Fixed In Version: chirp-20151130-1.fc23 chirp-20151130-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 05:22:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2015-11-29 11:30:14 EST
Description of problem:
Recent Chirp versions contain support for triple power Baofengs and also other improvements, please update to some 2015+ snap.

Version-Release number of selected component (if applicable):
chirp-0.4.1-1

How reproducible:
Always

Steps to Reproduce:
1. check version or presence of Baofeng BF-F8HP radio support

Actual results:
No Baofeng BF-F8HP support

Expected results:
Baofeng BF-F8HP support

Additional info:
I can also help you co-maintain.
Comment 1 Richard Shaw 2015-11-29 21:12:29 EST
I don't really want to update to a snapshot, it would be better if they would go ahead and tag a release as it's been a while.

Unless it's dependent on other updates I can pull in the latest uv5r.py to at least get you going.
Comment 2 Jaroslav Škarvada 2015-11-30 04:21:34 EST
(In reply to Richard Shaw from comment #1)
> I don't really want to update to a snapshot, it would be better if they
> would go ahead and tag a release as it's been a while.
>
I will try to write them, but it seems they moved to a snapshot release model, it even reports snapshot as release version in about dialog.
 
> Unless it's dependent on other updates I can pull in the latest uv5r.py to
> at least get you going.

Thanks, I have no problem with backport. But uv5r.py would require some patching, direct copy is not enough.

The BF-F8HP seems to support all the tri-power 2014+ classes of Baofengs (e.g. very probably, I didn't tested all: BF-UVB2Plus, UV-8HX, UV-5RTP, and many others), so it is good to have the support there.
Comment 3 Jaroslav Škarvada 2015-11-30 04:37:51 EST
Upstream bug:
http://chirp.danplanet.com/issues/3035
Comment 4 Jaroslav Škarvada 2015-11-30 10:16:12 EST
It doesn't seem there will be any release following the previous release model, reply from upstream:

Hi Jaroslov,

We're not doing releases anymore. It just doesn't make sense with our development process. This works just fine with Ubuntu because we generate the packages and upload to the PPA during every nightly build process. I don't (try to) do this with Fedora because the last survey I did indicated that there was little or no demand for Fedora packages.

If there is something I can do to better enable you to use the snapshots, please let me know.
Comment 5 Jaroslav Škarvada 2015-11-30 10:18:56 EST
So probably we will have to move to snapshot release model as well or drop the package. IMHO one refresh per release should be enough and shouldn't require much effort.
Comment 6 Richard Shaw 2015-11-30 12:18:27 EST
Bah that's annoying... So does the version never change? Do i need to bump the Epoch and change the version to 0? Or will they at lest maintain some sort of stable branch that I can patch against like I do for mythtv?
Comment 7 Richard Shaw 2015-11-30 12:53:55 EST
Ok, I posted to devel just to be sure but I'm planning on making the date the version, should work fine.
Comment 8 Richard Shaw 2015-11-30 14:25:53 EST
I just submitted a scratch build using the date as the version, when complete can you verify it works and addresses this bug?

http://koji.fedoraproject.org/koji/taskinfo?taskID=12017406
Comment 9 Jaroslav Škarvada 2015-11-30 14:46:59 EST
Thanks I am going to check with real HW.

I asked question about the new release model upstream:
http://chirp.danplanet.com/issues/3035#note-3

I.e. whether they are going to stay with this release model and if there is a chance there will be 0.5.1 version anytime.
Comment 10 Jaroslav Škarvada 2015-11-30 15:17:12 EST
Reply from upstream:

Well stick with the date, which is the whole version. So, we never plan to have an 0.5.0 version.
Comment 11 Jaroslav Škarvada 2015-11-30 15:56:59 EST
(In reply to Richard Shaw from comment #8)
> I just submitted a scratch build using the date as the version, when
> complete can you verify it works and addresses this bug?
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=12017406

Works great with my new Baofeng, thanks.
Comment 12 Fedora Update System 2015-11-30 17:20:18 EST
chirp-20151130-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7410210eb6
Comment 13 Fedora Update System 2015-12-01 17:30:44 EST
chirp-20151130-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update chirp'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-19c63f6f10
Comment 14 Fedora Update System 2015-12-03 11:03:16 EST
chirp-20151130-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update chirp'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7410210eb6
Comment 15 Fedora Update System 2015-12-14 05:22:30 EST
chirp-20151130-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-12-14 06:52:11 EST
chirp-20151130-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.