Bug 1286471 - Freeze after putting up a GRE device with ip
Freeze after putting up a GRE device with ip
Status: CLOSED DUPLICATE of bug 1272571
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 16:14 EST by Jaroslav Henner
Modified: 2015-11-30 11:33 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 07:45:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2015-11-29 16:14:25 EST
Description of problem:
When creating a tunnel, the system freezes.

Version-Release number of selected component (if applicable):
Linux jezevec 4.2.5-201.fc22.x86_64 #1 SMP Wed Oct 28 20:00:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
iproute-3.16.0-4.fc22.x86_64
kernel-4.1.8-200.fc22.x86_64
kernel-4.2.3-200.fc22.x86_64
kernel-4.2.5-201.fc22.x86_64

How reproducible:
always

Steps to Reproduce:
$ sudo ip tun add tun0 mode gre remote `resolveip -s x.y.z.redhat.com` local A.B.C.D  ttl 255
$ sudo ip a a 172.25.1.2/32 dev tun0
$ sudo ip l s dev tun0 up


Actual results:
Freeze, nothing in logs.


Expected results:
tunnel is doing it's tunneling stuff


Additional info:
Comment 1 Jaroslav Henner 2015-11-29 16:22:26 EST
I was able to reproduce two or three times in row and now I cannot.
Comment 2 Justin M. Forbes 2015-11-30 07:45:28 EST

*** This bug has been marked as a duplicate of bug 1272571 ***
Comment 3 Jaroslav Henner 2015-11-30 11:33:25 EST
Reproduced on

Linux jezevec 4.2.6-200.fc22.x86_64 #1 SMP Tue Nov 10 16:45:19 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

again, but then It worked fine. I am still unsure what is different between the reproducing and not-reproducing steps I do.

Note You need to log in before you can comment on or make changes to this bug.