Bug 1286474 - ipactl does not work correctly if administrator is an selinux confined user
ipactl does not work correctly if administrator is an selinux confined user
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 16:39 EST by wibrown@redhat.com
Modified: 2017-08-01 11:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-133.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 11:10:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wibrown@redhat.com 2015-11-29 16:39:59 EST
Description of problem:
type=AVC msg=audit(1448832291.010:5700): avc:  denied  { connectto } for  pid=17682 comm="ipactl" path="/run/slapd-IPA-EXAMPLE-COM.socket" scontext=staff_u:sysadm_r:sysadm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:dirsrv_t:s0 tclass=unix_stream_socket
type=AVC msg=audit(1448832291.010:5700): avc:  denied  { write } for  pid=17682 comm="ipactl" name="slapd-IPA-EXAMPLE-COM.socket" dev="tmpfs" ino=393592 scontext=staff_u:sysadm_r:sysadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dirsrv_var_run_t:s0 tclass=sock_file


All users on the system, not just sysadm_t should be able to access the ldapi socket on the host. In this case, it happens that ipactl fails to operate due to sysadm_t not having access to the socket.
Comment 1 wibrown@redhat.com 2016-02-16 21:21:13 EST
Something like this should do the trick.

policy/modules/roles/sysadm.te

optional_policy(`
    dirsrv_stream_connect(sysadm_t)
    dirsrv_manage_log(sysadm_t)
    dirsrv_manage_var_lib(sysadm_t)
    dirsrv_manage_var_run(sysadm_t)
    dirsrv_manage_config(sysadm_t)
')


Additionally, there is no reason NOT to allow staff_t or user_t to be able to use dirsrv_stream_connect.
Comment 2 Miroslav Grepl 2016-02-25 09:02:53 EST
Thank you. for testing.
Comment 6 errata-xmlrpc 2017-08-01 11:10:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861

Note You need to log in before you can comment on or make changes to this bug.