Bug 1286499 - [Docs] [Networking] Provide an outline of network QoS and the configuration thereof
[Docs] [Networking] Provide an outline of network QoS and the configuration t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Martin Lopes
Radek Bíba
http://docs.openstack.org/developer/n...
: Documentation
Depends On: 1194126
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 22:50 EST by Andrew Dahms
Modified: 2016-04-13 00:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 00:41:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2015-11-29 22:50:55 EST
In Red Hat Enterprise Linux OpenStack Platform 8, there are new capabilities for shaping and controlling network traffic. The following items must be added to the Networking Guide, ideally in the section on tenant networking -

* What is QoS, and to what network types can it be applied? For example, all 
  networks, or only tenant networks?
* How does QoS interact with organization - tenant - policy relationships.
* Are there any considerations in terms of usage or security? 
* How can users create and configure QoS policies?
Comment 1 Andrew Dahms 2015-12-01 22:16:37 EST
Assigning to Martin for review.
Comment 4 Andrew Dahms 2015-12-06 21:56:26 EST
Assigning Radek as the QA contact.

Radek - could you take a look at the changes for this bug?
Comment 5 Radek Bíba 2015-12-07 03:03:59 EST
The content looks good to me. There are two minor formatting suggestions that I have, and I see a kind of dash that probably won't work if copied and pasted to a reader's terminal:

1 - In:
RHEL OpenStack Platform 8 introduces support for network quality-of-service (QoS) policies. +
These policies...

Why the forced break ("+" at the end of the line)? I'd say the second sentence could be on the same line.

2 - In:
+----
+# neutron port-update <port id> –qos-policy bw-limiter
+----

You can make asciidoc render a nice replaceable parameter (in italics) this way:

[subs="verbatim,quotes"]
+----
+# neutron port-update _port id_ –qos-policy bw-limiter
+----

About the dash: notice the difference between – and -. The former is a Unicode dash (en dash, probably) and I'm pretty sure that neutron won't take –qos-policy, –max_kbps, and –max_burst_kbps as options; instead, it will think they are parameters. (I don't have an OSP 8 system at hand, but try e.g. "ls –l" on any Linux system.) Can you replace these dashes with standard ASCII minus signs (hyphens) so folks can copy and paste the commands?
Comment 6 Martin Lopes 2015-12-10 22:46:21 EST
 Removed '+' character as requested.
Comment 7 Martin Lopes 2015-12-10 22:48:40 EST
Replaced emdash characters.
Comment 8 Martin Lopes 2015-12-10 23:02:45 EST
Tested replaceable parameter formatting, but from the render testing I would suggest that the <port id> usage seems more easily distinguishable than italics?
 
In addition, using the <port id> style would persist through a copy/paste operation, compared to italics formatting, which would be lost.
Comment 9 Radek Bíba 2015-12-11 02:38:54 EST
Works for me. Marking as verified.
Comment 10 Andrew Dahms 2016-04-13 00:41:37 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.