Bug 1286527 - dnf-langpacks package missing in Workstation Live iso
dnf-langpacks package missing in Workstation Live iso
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 02:43 EST by Parag Nemade
Modified: 2016-01-06 15:23 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 15:23:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks files diff from F21 to F23 releases for Fedora Live workstation (5.17 KB, patch)
2015-11-30 02:43 EST, Parag Nemade
no flags Details | Diff

  None (edit)
Description Parag Nemade 2015-11-30 02:43:30 EST
Created attachment 1100369 [details]
ks files diff from F21 to F23 releases for Fedora Live workstation

Description of problem:
I compared F21 and F23 Workstation Live kickstart files and concluded that there is not much change and for langpacks plugin its same. In F21 we used yum-langpacks and then F22+ its replaced by dnf-langpacks in comps at same place in same standard group.

Problem is why dnf-langpacks is not getting added in Fedora Workstation Live media image?

Version-Release number of selected component (if applicable):
spin-kickstarts-0.23.6-1.fc23

How reproducible:
always

Steps to Reproduce:
1. take existing fedora-live-workstation.ks file
2. sudo livecd-creator -d --verbose --config=/usr/share/spin-kickstarts/fedora-live-workstation.ks --fslabel=Fedora-LiveCD-lang --cache=/var/cache/live
3.

Actual results:
no dnf-langpacks package in Live image

Expected results:
dnf-langpacks should be available like we had yum-langpacks till F21 releases.

Additional info:
Attached are related kickstart files diff to generate Fedora Workstation Live media from F21 to F23.
Comment 1 Parag Nemade 2015-12-13 10:27:24 EST
Ping spin-kickstart developers...
I am not sure owner (kanarip) of this package is still around based on datagrepper low activity results.
Comment 2 Kevin Fenzi 2015-12-13 14:58:17 EST
I asked kalev to look into this one... not sure if he's had a chance yet.
Comment 3 Parag Nemade 2015-12-15 06:50:18 EST
Thanks Kevin, meanwhile I will also try to find more information about this problem.
Comment 4 Kalev Lember 2015-12-16 13:03:37 EST
Workstation doesn't use the standard group, which is probably the reason why it doesn't show up. I wonder if we should run this by the Workstation WG before adding it to the workstation group? I could do that at the next meeting.
Comment 5 Parag Nemade 2015-12-17 01:14:19 EST
When I tried to find more about this problem initially, I am confused why almost similar kickstart file worked fine in F21 and pulled yum-langpacks successfully.
Comment 6 Jens Petersen 2015-12-22 01:39:57 EST
(In reply to Kalev Lember from comment #4)
> Workstation doesn't use the standard group, which is probably the reason why
> it doesn't show up. I wonder if we should run this by the Workstation WG
> before adding it to the workstation group? I could do that at the next
> meeting.

I think it is a good idea - or at least on the desktop list.
Comment 7 Michael Catanzaro 2016-01-06 11:07:17 EST
(In reply to Kalev Lember from comment #4)
> Workstation doesn't use the standard group, which is probably the reason why
> it doesn't show up. I wonder if we should run this by the Workstation WG
> before adding it to the workstation group? I could do that at the next
> meeting.

At the WG meeting today, nobody was aware of any reason to not install dnf-langpacks. I think the only reason it is not currently installed by default is that nobody ever added it. So I think it's fine to add.

Don't edit the kickstart though, that's not the right place to add package-level dependencies. Edit the workstation-product group in comps.
Comment 8 Michael Catanzaro 2016-01-06 15:23:26 EST
I've added it to @workstation-product:

https://git.fedorahosted.org/cgit/comps.git/commit/?id=cff34ea16fabf3ca609087efa262c3219e5b138b

Note You need to log in before you can comment on or make changes to this bug.