This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286546 - udev bcache rules vanish
udev bcache rules vanish
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bcache-tools (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rolf Fokkens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 03:32 EST by Pierre Juhen
Modified: 2015-11-30 14:13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 14:13:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Juhen 2015-11-30 03:32:10 EST
Description of problem:

I installed an ssd as a caching device. root file system is on the cache backend.
I installed bcache-tools and built a new initramfs.

It fails to boot, because the root filesystem is not found.

I found that the file /usr/lib/udev/rules.d/69-bcache.rules is not present during boot phase.

But lsinitrd shows it's present in the initramfs...

I reinstalled bcache-tools, rebuilt initarfms a lot...

Version-Release number of selected component (if applicable):
Latest release of Fedora 23 (all components up to date).

How reproducible:
Happens systematically.

Actual results:
Booting stops with dracut prompt
Loading module bcache, registering devices and activating lvm, everything goes fine after theis manual process.

Additional info:
Becoming crazy


Thanks,
Comment 1 Harald Hoyer 2015-11-30 05:00:57 EST
bcache-tools provides the bcache support for dracut. Reassigning.
Comment 2 Rolf Fokkens 2015-11-30 07:52:34 EST
If lsinitrd shows it's there, and it's not in the actual initrd I strongly suspect that not the right initrd is used.

Maybe dracut is run while /boot is not proper mounted?

Consider using dracut specifying a manual fabricated initramfs name (like adding a ".manual" extension". The during boot from the grub menu modify the requested boot entry so the fabricated initramfs name is used. Now boot, and see if grub actually finds the initramfs.
Comment 3 Pierre Juhen 2015-11-30 14:13:03 EST
Shame on me !!!

To install the cache, I copied (using dd) logical volumes from one volume group to another.

I had two copies of the filesystem with the same uuid.

It was the old one, without bcache, that provided initramfs.

Thanks Rolf, for providing the clue§

Note You need to log in before you can comment on or make changes to this bug.