Bug 1286557 - Uncaught exception when trying to move a disk (when there is no active storage domain in the data center to move the disk to)
Uncaught exception when trying to move a disk (when there is no active storag...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1
Unspecified Unspecified
low Severity medium (vote)
: ovirt-3.6.1
: 3.6.1.2
Assigned To: Tal Nisan
Petr Matyáš
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 04:05 EST by Petr Matyáš
Modified: 2016-02-10 13:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:18:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
tnisan: blocker?
pmatyas: planning_ack?
tnisan: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
screenshot (142.20 KB, image/png)
2015-11-30 04:05 EST, Petr Matyáš
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50022 master MERGED webadmin: Exception thrown when trying to move/copy a disk with no up SDs Never
oVirt gerrit 50025 ovirt-engine-3.6 MERGED webadmin: Exception thrown when trying to move/copy a disk with no up SDs Never
oVirt gerrit 50026 ovirt-engine-3.6.1 MERGED webadmin: Exception thrown when trying to move/copy a disk with no up SDs Never

  None (edit)
Description Petr Matyáš 2015-11-30 04:05:49 EST
Created attachment 1100393 [details]
screenshot

Description of problem:
There is an uncaught exception when I try to move any disk
09:55:23.927 Mon Nov 30 09:55:23 GMT+100 2015 
SEVERE: Uncaught exception: java.util.NoSuchElementException
	at Unknown.ms(Unknown Source)
	at Unknown.qs(Unknown Source)
	at Unknown.ss(Unknown Source)
	at Unknown.mYf(Unknown Source)
	at Unknown._Qf(Unknown Source)
	at Unknown.dRf(Unknown Source)
	at Unknown.dlq(Unknown Source)
	at Unknown.CHr(Unknown Source)
	at Unknown.Wno(Unknown Source)
	at Unknown.roo(Unknown Source)
	at Unknown.qoo(Unknown Source)
	at Unknown.brq(Unknown Source)
	at Unknown.l6q(Unknown Source)
	at Unknown.orq(Unknown Source)
	at Unknown.CMn(Unknown Source)
	at Unknown.FMn(Unknown Source)
	at Unknown.wQn(Unknown Source)
	at Unknown.zQn(Unknown Source)
	at Unknown.cPn(Unknown Source)
	at Unknown.fPn(Unknown Source)
	at Unknown.BHe(Unknown Source)
	at Unknown.Evk(Unknown Source)
	at Unknown.r3(Unknown Source)
	at Unknown.K3(Unknown Source)
	at Unknown.Duf/c.onreadystatechange<(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
1 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:24007:11772
LCe() 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:24007
UDe() 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:22059
TDe() 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:19639
iEe() 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:9938
GIk() 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:24049
gu() 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:18278
au() 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:21165
_t/<() 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:20528

The dialog for moving the disk won't load at all and page refresh is necessary.

Version-Release number of selected component (if applicable):
rhevm-3.6.1-0.2.el6.noarch
ovirt-engine-3.6.1-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. click on some disk
2. click on Move button
3.

Actual results:
dialog appears without any text and error shows up

Expected results:
dialog appears normally with no error

Additional info:
Comment 1 Allon Mureinik 2015-12-01 11:01:03 EST
Tal - can we short-loop this please?
Comment 2 Tal Nisan 2015-12-02 05:13:16 EST
Yes, after trying to reproduce, it does not occur with every disk but only when there is no active storage domain in the data center to move the disk to.
Given this finding, reducing the severity to high since disks can be moved in the system and failure occurs only when no relevant storage domain is found which renders the move disk dialog useless anyway.
Comment 3 Sandro Bonazzola 2015-12-10 07:42:04 EST
This bug is referenced in ovirt-engine 3.6.1.2 git log.
Please check if the BZ is ready to be moved to QE and set target release accordingly.
Comment 4 Petr Matyáš 2015-12-15 06:59:29 EST
Verified on 3.6.1-4
Comment 5 Sandro Bonazzola 2015-12-16 07:18:45 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.