Bug 1286609 - Amazon instances take a long time to get deleted
Amazon instances take a long time to get deleted
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.6.0
Assigned To: Joe Vlcek
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 05:22 EST by Pete Savage
Modified: 2015-12-03 11:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 15:08:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2015-11-30 05:22:55 EST
Description of problem: Amazon instances do not get Archived on deletion


Version-Release number of selected component (if applicable): 5.5.0.12


How reproducible: 100%


Steps to Reproduce:
1. Add an ec2 provider
2. Add an instance outside of cloudforms
3. Refresh the provider
4. Delete/Terminate the instance
5. Refresh the provider

Actual results: Provider shows the instance as powered off


Expected results: Instance should be archived


Additional info:
Comment 2 Pete Savage 2015-11-30 10:53:20 EST
I will do further tests, initially it seemed like it was never getting deleted. New instances show up immediately on refresh, but old ones take a long time to get deleted. Minimum over 10 minutes.
Comment 3 Greg Blomquist 2015-11-30 13:30:35 EST
We'll probably have to gather data on what the instance looks like in Amazon.  Or, more specifically, what the instance looks like in results from the API calls we make to Amazon when gathering inventory.
Comment 4 Joe Vlcek 2015-12-02 15:08:03 EST
Cloudform's behavior reflects that of EC2 in this regard.

Cloudforms does not mark an instance as "Archived" until the provider no longer reports on that instance. EC2 will continue to report on an instance for about
an hour after the instance has been terminated.

Both the EC2 and Cloudforms dashboards align, listing the "Power State" as "terminated" during this time.

Once EC2 discontinues reporting on the instance Cloudforms then moves it
to "Archived" but, again, this could take an hour. This can be observed by
monitoring both the EC2 and Cloudforms dashboards.

I do not feel this is a bug so I will mark it as such. If you disagree
please let me know.
Comment 5 Pete Savage 2015-12-03 11:31:07 EST
Joe, this is absolutely fine, there was an issue with our mgmtsystem that pulls data from EC2, this has now been resolved. Apologies!

Note You need to log in before you can comment on or make changes to this bug.