Bug 1286613 - [RFE] Check/ to allow/ add an option in RHEVM to verify connection to VLAN from RHEVM GUI.
[RFE] Check/ to allow/ add an option in RHEVM to verify connection to VLAN fr...
Status: CLOSED DUPLICATE of bug 856337
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.5.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Scott Herold
Gil Klein
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 05:40 EST by Ulhas Surse
Modified: 2016-02-17 08:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 08:29:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulhas Surse 2015-11-30 05:40:14 EST
3. What is the nature and description of the request?
   The request is to treat sure the VLAN operating within the RHEV Manager network settings. Today there is no confirmation that the VLAN is in operation, even after configure it within the manager if the network team has not properly mapped interface.

4. Why does the customer need this? (List the business requirements here)
   Due to lack of reliability in the delivery of VLANs on network interfaces by the network team.
Today we need to run tcpdump commands within the host to make sure that the VLAN is working.

5. How would the customer like to achieve this? (List the functional requirements here)
   Through the Network Configuration tab. The addition of a new network before saving the network configuration, the host performs the traffic of test vlan.

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
   Yes

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
   No.

8. Does the customer have any specific time-line dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
   No.

9. Is the sales team involved in this request and do they have any additional input?
   No.

10. List any affected packages or components.
    No.
    
    use tcpdump with the command:
    # tcpdump -i -uw interface - | tcpdump-en -r - vlan number

11. Would the customer be able to assist in testing this functionality if implemented?
    Yes

Additional Info:
----------------
feature request to check/ to allow/ add an option in RHEVM to verify connection to VLAN from RHEVM GUI instead to check it from host side. 

The idea of the open case is to suggest that there is a test within the network tab on the RHEV-M.

The tcpdump command:
# Tcpdump -i in 1 -uw - | tcpdump-en -r - vlan 123

- Return output if the VLAN is delivered correctly on the host.
- This feature could not be added to the network settings in the Manager (RHEV).
- Today we need to do this test on the hosts to make sure that the VLAN was successfully delivered by the network team.
Comment 2 Dan Kenigsberg 2016-01-31 09:42:24 EST
I think that network labels can come to your service. You can set a label on a nic of each of your hosts. Then, when you set the same label on a newly-defined network, the network would be automatically configured on all of the hosts that carry that the label.

http://www.ovirt.org/Features/NetworkLabels

would that satisfy your RFE?
Comment 3 Dan Kenigsberg 2016-01-31 09:47:30 EST
Please strike my comment 2. It refers to another bug 1287150.
Comment 4 Dan Kenigsberg 2016-01-31 09:56:45 EST
This RFE partially overlaps bug 994170, as they both discuss means to tell whether a host's network config is properly connected to the external world. Your suggested means to test connectivity does not require active pings to  destination hosts, but it does require promiscuous listening and a noisy vlan, so I am not sure which method is better.

Would the issue that the customer have faced be fixed if Engine has reported LLDP/CDP configuration on each host interface? I think that it can solve many configuration mishaps and is planned in bug 856337.
Comment 6 Dan Kenigsberg 2016-02-17 08:29:28 EST

*** This bug has been marked as a duplicate of bug 856337 ***

Note You need to log in before you can comment on or make changes to this bug.