Bug 1286622 - Openstack Cloud provider refresh fails when having networks with both IPv4 and IPv6 subnets assigned
Openstack Cloud provider refresh fails when having networks with both IPv4 an...
Status: CLOSED DUPLICATE of bug 1278654
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 06:12 EST by Marius Cornea
Modified: 2015-11-30 07:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 07:14:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-11-30 06:12:05 EST
Description of problem:
Openstack Cloud provider refresh fails when having networks with both IPv4 and IPv6 subnets assigned

Version-Release number of selected component (if applicable):
5.5.0.12

How reproducible:
100%

Steps to Reproduce:
1. Add Openstack cloud provider which has neutron networks with both IPv4 and IPv6 subnets
2. Refresh provider

Actual results:
Refresh fails:
Error - Less Than A Minute Ago
undefined method `fetch_path' for nil:NilClass

Expected results:
Refresh completes.

Additional info:
Full trace:
[----] E, [2015-11-30T06:04:06.687173 #13973:9fb988] ERROR -- : MIQ(ManageIQ::Providers::Openstack::CloudManager::Refresher#refresh) EMS: [openstack6], id: [1] Refresh failed
[----] E, [2015-11-30T06:04:06.687493 #13973:9fb988] ERROR -- : [NoMethodError]: undefined method `fetch_path' for nil:NilClass  Method:[rescue in block in refresh]
[----] E, [2015-11-30T06:04:06.687683 #13973:9fb988] ERROR -- : /var/www/miq/vmdb/app/models/manageiq/providers/openstack/refresh_parser_common/networks.rb:172:in `parse_network_router'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/refresh_parser_common/networks.rb:40:in `block in get_network_routers'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/refresh_parser_common/helper_methods.rb:14:in `process_collection_item'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/refresh_parser_common/helper_methods.rb:8:in `block in process_collection'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/refresh_parser_common/helper_methods.rb:8:in `each'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/refresh_parser_common/helper_methods.rb:8:in `process_collection'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/refresh_parser_common/networks.rb:40:in `get_network_routers'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/cloud_manager/refresh_parser.rb:62:in `ems_inv_to_hashes'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/cloud_manager/refresh_parser.rb:12:in `ems_inv_to_hashes'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/cloud_manager/refresher.rb:6:in `parse_inventory'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:19:in `block in refresh'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:7:in `each'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:7:in `refresh'
/var/www/miq/vmdb/app/models/manageiq/providers/base_manager/refresher.rb:10:in `refresh'
/var/www/miq/vmdb/app/models/ems_refresh.rb:77:in `block in refresh'
/var/www/miq/vmdb/app/models/ems_refresh.rb:76:in `each'
/var/www/miq/vmdb/app/models/ems_refresh.rb:76:in `refresh'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:334:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:153:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:128:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:29:in `start_worker'
/var/www/miq/vmdb/lib/workers/bin/worker.rb:2:in `<top (required)>'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/runner.rb:60:in `load'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/runner.rb:60:in `<top (required)>'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:123:in `require'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:90:in `runner'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.5/lib/rails/commands.rb:17:in `<top (required)>'
/var/www/miq/vmdb/bin/rails:4:in `require'
/var/www/miq/vmdb/bin/rails:4:in `<main>'
Comment 2 Marius Cornea 2015-11-30 06:13:05 EST
[root@dell-c6220-11 ~(keystone_admin)]# neutron net-list
+--------------------------------------+-----------------+------------------------------------------------------+
| id                                   | name            | subnets                                              |
+--------------------------------------+-----------------+------------------------------------------------------+
| c1653f37-3b87-425c-a426-67355639b62a | internal_ipv4_6 | 80f5a624-422e-4273-9218-104ded1c68ee 2003:db3::/64   |
|                                      |                 | 78355a09-0b28-4e85-afa2-14d48350a190 2002:db2::/64   |
|                                      |                 | 6f8b91c3-0b72-4f41-9101-ad7c2fccbb1d 192.168.1.0/24  |
|                                      |                 | 9f044bc3-cac9-4c10-aa71-f105ee59a3cf 2001:db1::/64   |
| f5af640e-3bd7-49a4-9c82-66b512cc8bb9 | private         | e597776b-ec1c-4e81-8e99-94f43e55988b 10.0.0.0/24     |
| 59cbcd58-1574-41e5-aaf5-0d9eb33cbe45 | public          | 3e933b59-cc20-4662-9c94-9920934d8375 172.24.4.224/28 |
+--------------------------------------+-----------------+------------------------------------------------------+
Comment 3 Ladislav Smola 2015-11-30 07:14:36 EST

*** This bug has been marked as a duplicate of bug 1278654 ***

Note You need to log in before you can comment on or make changes to this bug.