Bug 1286650 - An option to do unsafe live migration of VirtualDomain
An option to do unsafe live migration of VirtualDomain
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Oyvind Albrigtsen
cluster-qe@redhat.com
:
Depends On: 1242181
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 07:08 EST by Oyvind Albrigtsen
Modified: 2016-05-10 15:15 EDT (History)
6 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-28.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1242181
Environment:
Last Closed: 2016-05-10 15:15:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Working patch (5.07 KB, patch)
2015-12-01 05:54 EST, Oyvind Albrigtsen
no flags Details | Diff

  None (edit)
Comment 2 Oyvind Albrigtsen 2015-12-01 05:54 EST
Created attachment 1100831 [details]
Working patch
Comment 3 Oyvind Albrigtsen 2015-12-01 05:55:11 EST
Updated patch for RHEL6 and tested and confirmed that it's working.
Comment 4 Oyvind Albrigtsen 2015-12-21 07:29:16 EST
Before:
Unable to do live migration when cache mode isnt set to none.

After:
Able to do live migration when cache mode isnt set to none by setting migrate_options="--unsafe"
Comment 5 Oyvind Albrigtsen 2016-01-08 04:54:01 EST
# pcs resource create VM VirtualDomain config=/etc/libvirt/qemu/vm.xml migration_transport=ssh meta allow-migrate=true


Before:
# rpm -q resource-agents
resource-agents-3.9.5-24.el6_7.1.x86_64

# pcs resource move VM host2
# tail -f /var/log/cluster/corosync.log
Live migration fails with: Unsafe migration: Migration may lead to data corruption if disks use cache != none


After:
# rpm -q resource-agents
resource-agents-3.9.5-28.el6.x86_64

# pcs resource update VM migrate_options="--unsafe"
# pcs resource move VM host2
# tail -f /var/log/cluster/corosync.log
INFO: vmhost: Starting live migration to host2 (using virsh --connect=qemu:///system --quiet migrate --live --unsafe vmhost qemu+ssh://host2/system ).
INFO: vmhost: live migration to host2 succeeded.
Comment 7 Jaroslav Kortus 2016-04-12 17:06:42 EDT
without migrate_options:

VirtualDomain(vm)[14290]:	2016/04/12_22:52:09 INFO: rhel6.5: Starting live migration to duck-01 (using virsh --connect=qemu:///system --quiet migrate --live  rhel6.5 qemu+ssh://duck-01/system ).

with migrate_options="--unsafe"
VirtualDomain(vm)[15261]:	2016/04/12_22:54:39 INFO: rhel6.5: Starting live migration to duck-01 (using virsh --connect=qemu:///system --quiet migrate --live --unsafe rhel6.5 qemu+ssh://duck-01/system ).

The domain migrated successfully.

Thing to add here:
* if GFS2 is used that migration is already considered safe and --unsafe is not needed (same applies to OCFS, SMB and NFS shares and perhaps others).

Verified with resource-agents-3.9.5-34.el6.x86_64.
Comment 9 errata-xmlrpc 2016-05-10 15:15:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0735.html

Note You need to log in before you can comment on or make changes to this bug.