Bug 128666 - X restarted by gdm
Summary: X restarted by gdm
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-27 19:33 UTC by Tethys
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 10:05:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (15.33 KB, application/x-gzip)
2004-12-06 21:24 UTC, Tethys
no flags Details
message, Xorg.0.log, and xorg.conf - X server restart / OpenGL (6.79 KB, application/octet-stream)
2004-12-27 01:31 UTC, Eric Durant
no flags Details
/var/log/messages extract (1.47 KB, text/plain)
2005-01-05 18:14 UTC, Tethys
no flags Details
Xorg.0.log (9.38 KB, text/plain)
2005-01-05 18:15 UTC, Tethys
no flags Details
Xorg log file (19.86 KB, application/octet-stream)
2005-01-31 16:02 UTC, Tethys
no flags Details

Description Tethys 2004-07-27 19:33:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
I was browsing the web with Mozilla. The X server just restarted
with no warning or input from me. The only clue I could find was
the following entry in /var/log/messages:

Jul 27 20:26:15 leto gdm[10222]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0

I'd guess that the fault lies with X itself, rather than gdm.

This has happened to me a few times recently, with no apparent
link between them to indicate what's triggering it.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. N/A
2.
3.
    

Additional info:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100
QY [Radeon 7000/VE]

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 3
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 3
cpu MHz         : 2993.676

Intel D865PERL motherboard

Linux leto.astradyne.corp 2.6.7 #1 SMP Wed Jun 16 20:15:39 BST 2004
i686 i686 i386 GNU/Linux

Comment 1 Tethys 2004-11-11 17:22:27 UTC
Just had this happen to me at work, again on FC2, this time with a
newer graphics card (but again a Radeon):


Nov 11 17:12:05 isengard gdm[2877]: gdm_slave_xioerror_handler: Fatal
X error - Restarting :0
Nov 11 17:12:05 isengard gdm(pam_unix)[2877]: session closed for user tet


01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon
9200] (rev 01)

Dual Xeon Compaq XP6000 workstation:

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) CPU 2.80GHz
stepping        : 7
cpu MHz         : 2791.844
cache size      : 512 KB

Linux isengard.accucard.com 2.6.8-1.521smp #1 SMP Mon Aug 16 09:25:06
EDT 2004 i686 i686 i386 GNU/Linux

Comment 2 Tethys 2004-11-11 17:26:52 UTC
s/XP600/xw600/

Comment 3 Mike A. Harris 2004-12-06 18:00:49 UTC
Please upgrade your entire Fedora Core 2 system, including xorg-x11
and the kernel, to the latest official Red Hat released updates
for FC2.

Once you've ensured you are running the latest versions of all rpm
packages, if the problem is still reproduceable, please attach all
X server log files from /var/log/Xorg*, as well as the X server
config file, and /var/log/messages from boot time onward, from a
session which has triggered this problem.

Do you think this might be related to OpenGL screensavers perhaps?
Please indicate if there are any specific applications or other
software which triggers the problem.  We'll need enough information
to be able to reliably reproduce the problem in order to investigate.



Comment 4 Mike A. Harris 2004-12-06 18:01:36 UTC
Setting status to "NEEDINFO", pending attachment of information
requested in comment #3 above.

Comment 5 Tethys 2004-12-06 21:00:05 UTC
Already up to date with the latest packages (as I was at the time
I reported it). Incidentally, I would normally upgrade to FC3, but
the machines on which I've done so are quite unstable, and the two
boxen on which I've seen this problem are too heavily used to be
subjected to that level of instability.

It's definitely not related to OpenGL screensavers -- this problem
has manifested itself several times, but only ever when the machine
was in active use, usually on a keypress of mouse move, and not when
screensavers were running (that problem is logged separately as
another bug :-)

I'll attach the Xorg logs when it next happens.

Comment 6 Tethys 2004-12-06 21:17:41 UTC
"As if by magic, a shopkeeper appeared". I appear to have a saved
copy of the X log from the last time it crashed. Attached...

Comment 7 Tethys 2004-12-06 21:24:56 UTC
Created attachment 107999 [details]
X log

Comment 8 Eric Durant 2004-12-27 01:31:50 UTC
Created attachment 109131 [details]
message, Xorg.0.log, and xorg.conf - X server restart / OpenGL

I'm experiencing what seems to be the same bug (X server restart with
gdm_slave_xioerror_handler) under both FC2 (up2date 17 December 2004) and FC3
(up2date 26 December 2004).  The problem started under FC2 in early-mid
December, I think, after doing an up2date -u; until then, FC2 appeared to run
correctly.  Specifically, any application that uses OpenGL seems to cause the
error.	I've tried this with very simple GLUT and QGLWidget test applications
that simply draw a white box on a black background to show that OpenGL is
working.  I'm running under VMWare 4.5.2 and, of course, have enabled GLX in
xorg.conf.  These applications worked fine under RH9 and FC1, and under FC2
until a recent update.	I've attached a Zip file with "messages" since the last
shutdown, "Xorg.0.log" and "xorg.conf".  Please let me now if any additional
information is needed.

Comment 9 Tethys 2005-01-05 18:13:53 UTC
Had this again today at work, only much worse than before. It was
crashing 2 or 3 minutes after logging in, repeatably. This even
survived a power cycle. However, completely removing the power lead
for a few minutes seems (so far) to have cured it. Relevant logs
attached...

Comment 10 Tethys 2005-01-05 18:14:31 UTC
Created attachment 109382 [details]
/var/log/messages extract

Comment 11 Tethys 2005-01-05 18:15:10 UTC
Created attachment 109383 [details]
Xorg.0.log

Comment 12 Tethys 2005-01-05 18:19:42 UTC
Oops. That last attachment is gzipped, not plain text.

Also maybe noteworthy -- unlike previous occurences of this,
switching to a text console with Ctrl-Alt-F1 after the X
restart deadlocked my machine, to the point where keyboard
LEDs stopped working and even magic sysrq wasn't able to
reboot the box.

Comment 13 Tethys 2005-01-05 18:24:11 UTC
Sigh. I obviosuly spoke too soon. Just restarted again, so
confiscating the power was only a temporary fix. Also this is
definitely not OpenGL related. I had no GL apps running.

Comment 14 Tethys 2005-01-05 18:49:53 UTC
Well, some progress at least. I've now found a way to trigger this
bug reliably, so it's no longer intermittent. Click on the "edit"
link against the Xorg.0.log attachment to this bug. If it doesn't
die at that point, then moving the cursor over the attachment name
input box always causes the X server to die immediately.

Comment 15 Tethys 2005-01-31 16:01:06 UTC
...and another crash. /var/log/messages contains the same error
(I've included the previous lines, as they're temporally close
enough to the crash that it may be related):

Jan 31 14:29:50 isengard modprobe: FATAL: Error running install
command for sound_slot_1 
Jan 31 14:38:08 isengard last message repeated 2 times
Jan 31 14:42:13 isengard last message repeated 2 times
Jan 31 14:43:33 isengard last message repeated 2 times
Jan 31 15:45:04 isengard last message repeated 2 times
Jan 31 15:46:17 isengard last message repeated 2 times
Jan 31 15:46:17 isengard modprobe: FATAL: Error running install
command for sound_slot_1 
Jan 31 15:48:34 isengard gdm[2844]: gdm_slave_xioerror_handler: Fatal
X error

X log is attached

Comment 16 Tethys 2005-01-31 16:02:34 UTC
Created attachment 110442 [details]
Xorg log file

Comment 17 Mike A. Harris 2005-02-01 10:05:39 UTC
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "CURRENTRELEASE" of FC3.


Note You need to log in before you can comment on or make changes to this bug.