Bug 1286711 - manpage for tc needs info on filters
manpage for tc needs info on filters
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute (Show other bugs)
7.2
All All
medium Severity medium
: rc
: ---
Assigned To: Phil Sutter
Jaroslav Aster
: Documentation
Depends On:
Blocks: 1203710 1301628 1313485
  Show dependency treegraph
 
Reported: 2015-11-30 09:52 EST by Jaroslav Aster
Modified: 2016-11-03 19:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: iproute-3.10.0-58.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1093726
Environment:
Last Closed: 2016-11-03 19:36:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Aster 2015-11-30 09:52:40 EST
Iproute on rhel-7 needs to be updated too. It needs to be consistent with rhel-6.

iproute-3.10.0-54.el7

+++ This bug was initially created as a clone of Bug #1093726 +++

Description of problem:
  Specifically, there is nothing on handles or cgroups.  The See-Also doc site (http://lartc.org) has not at all on cgroups.


Version-Release number of selected component (if applicable):

  2.6.32-431.3.1.el6.x86_64

  The tc manpage last line is:
"iproute2                       16 December 2001                          TC(8)"

How reproducible:
  Always


Steps to Reproduce:
1.  Attempt to learn how stuff works
2.  Fail
3.

Actual results:
  No Info

Expected results:
  In the "tc" manpage: See-Also links, or embedded info, for specifics for all the available filters.

  A Resource Management Guide chapter on tc would also be good.

Additional info:
  There's a link in the reverse direction, from cgroups to tc, in the Resource_Management_Guide (section 3.8: net_cls), which suggests the tc manpage.

--- Additional comment from Phil Sutter on 2015-10-29 04:58:07 EDT ---

A patch series adding man pages for filters has been sent upstream and accepted: http://thread.gmane.org/gmane.linux.network/384390
Comment 1 Phil Sutter 2016-01-21 10:57:54 EST
This should be trivial: Backport my patch series adding tc filter man pages minus those which don't exist in RHEL7 (if any).
Comment 6 errata-xmlrpc 2016-11-03 19:36:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2162.html

Note You need to log in before you can comment on or make changes to this bug.