Bug 1286724 - PackageKit writes wrong reason into dnf's yumdb
PackageKit writes wrong reason into dnf's yumdb
Status: CLOSED DUPLICATE of bug 1259865
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 10:20 EST by Michal Luscon
Modified: 2015-11-30 10:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 10:48:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Luscon 2015-11-30 10:20:14 EST
Hi Richard,

we found out that the PackageKit marks all of installed packages with reason "dependency" in dnf's yumdb despite the fact that the actual reason should be "user installed". This can cause an autoremoval of packages installed by PackageKit if user consequently uses DNF.

Steps to reproduce:

1, install vim via command not found
2, cat /var/lib/dnf/yumdb/v/*vim*/reason
Comment 1 Rex Dieter 2015-11-30 10:48:54 EST

*** This bug has been marked as a duplicate of bug 1259865 ***

Note You need to log in before you can comment on or make changes to this bug.