Bug 1286743 - Ansible (openshift-clients really) should install git automatically
Ansible (openshift-clients really) should install git automatically
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.1.1
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 11:09 EST by Jason Callaway
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: atomic-openshift-3.1.1.0-0.git.0.e6a4ea2.el7aos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:42:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Callaway 2015-11-30 11:09:41 EST
Description of problem: the git binary is not present, which breaks oc new-app


Version-Release number of selected component (if applicable):
# rpm -q openshift
openshift-3.0.2.0-0.git.33.f6b0f24.el7ose.x86_64

How reproducible:
# oc new-app https://github.com/jason-callaway/phpinfo.git
error: cannot clone repository https://github.com/jason-callaway/phpinfo: exec: "git": executable file not found in $PATH
Comment 1 Jason DeTiberus 2015-11-30 12:03:10 EST
I think we should probably handle this through packaging rather than through the installer.

For 3.0.2:
openshift should require git

For 3.1+:
atomic-openshift-clients should require git
Comment 2 Scott Dodson 2015-11-30 12:54:55 EST
Agreed, origin pr.

https://github.com/openshift/origin/pull/6126
Comment 3 Scott Dodson 2015-12-21 09:12:22 EST
git has been added as an rpm dependency to the clients rpm.
Comment 4 Ma xiaoqiang 2015-12-22 20:13:15 EST
Check on puddle [ose-3.1.1/2015-12-19.3]

# yum install atomic-openshift

Dependencies Resolved
=================================
 Package                         
=================================
Installing:
 atomic-openshift                
Installing for dependencies:
 atomic-openshift-clients        
 git                             
 perl-Git     

                   
# yum install atomic-openshift-clients

Dependencies Resolved
==========================================
 Package                                  
==========================================
Installing:
 atomic-openshift-clients                 
Installing for dependencies:
 git                                      
 perl-Git                                 

Transaction Summary
==========================================
Install  1 Package (+2 Dependent packages)

Move it to VERIFIED
Comment 6 errata-xmlrpc 2016-01-27 14:42:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.