Bug 1286744 - [abrt] dnf: output.py:2194:scriptout:OSError: [Errno 5] Input/output error
[abrt] dnf: output.py:2194:scriptout:OSError: [Errno 5] Input/output error
Status: CLOSED DUPLICATE of bug 1256943
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:057339ace8fb1d5fba9baa8eeac...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 11:11 EST by Joe Doss
Modified: 2016-08-08 07:34 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-08 07:34:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (217.37 KB, text/plain)
2015-11-30 11:11 EST, Joe Doss
no flags Details
File: backtrace (790 bytes, text/plain)
2015-11-30 11:11 EST, Joe Doss
no flags Details
File: dnf-makecache.log (1.92 MB, text/plain)
2015-11-30 11:12 EST, Joe Doss
no flags Details
File: environ (2.01 KB, text/plain)
2015-11-30 11:12 EST, Joe Doss
no flags Details

  None (edit)
Description Joe Doss 2015-11-30 11:11:51 EST
Description of problem:
Most likely related to https://bugzilla.redhat.com/show_bug.cgi?id=1285319 segfault during a dnf update.

Version-Release number of selected component:
dnf-1.1.4-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /bin/dnf update
executable:     /bin/dnf
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
output.py:2194:scriptout:OSError: [Errno 5] Input/output error

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/dnf/yum/rpmtrans.py", line 431, in callback
    self._scriptStop(bytes, total, h);
  File "/usr/lib/python3.4/site-packages/dnf/yum/rpmtrans.py", line 573, in _scriptStop
    self._scriptout()
  File "/usr/lib/python3.4/site-packages/dnf/yum/rpmtrans.py", line 219, in _scriptout
    display.scriptout(msgs)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 2194, in scriptout
    sys.stdout.write(ucd(msgs))
OSError: [Errno 5] Input/output error

Local variables in innermost frame:
msgs: b'warning: %post(gvfs-1.26.2-1.fc23.x86_64) scriptlet failed, signal 1\n'
self: <dnf.cli.output.CliTransactionDisplay object at 0x7f9afb779470>
Comment 1 Joe Doss 2015-11-30 11:11:56 EST
Created attachment 1100536 [details]
File: _var_log_dnf.log
Comment 2 Joe Doss 2015-11-30 11:11:57 EST
Created attachment 1100537 [details]
File: backtrace
Comment 3 Joe Doss 2015-11-30 11:12:04 EST
Created attachment 1100538 [details]
File: dnf-makecache.log
Comment 4 Joe Doss 2015-11-30 11:12:05 EST
Created attachment 1100539 [details]
File: environ
Comment 5 Fedora Admin XMLRPC Client 2016-07-08 05:36:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Igor Gnatenko 2016-08-08 07:34:41 EDT

*** This bug has been marked as a duplicate of bug 1256943 ***

Note You need to log in before you can comment on or make changes to this bug.