Bug 1286761 - Snapshot creation fails with "Failed to pause tier in snap prevalidate" message on tier volume
Snapshot creation fails with "Failed to pause tier in snap prevalidate" messa...
Status: CLOSED DUPLICATE of bug 1278798
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot (Show other bugs)
3.1
x86_64 Unspecified
high Severity high
: ---
: ---
Assigned To: rjoseph
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 11:46 EST by Arthy Loganathan
Modified: 2016-09-17 08:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 10:25:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthy Loganathan 2015-11-30 11:46:39 EST
Description of problem:
Snapshot creation fails with "Failed to pause tier in snap prevalidate" message on tier volume

Version-Release number of selected component (if applicable):
glusterfs-server-3.7.5-6.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a volume.
2. Write IOs
3. Attach dist-rep(2X2) tier to the volume.
4. Create snapshot.

Actual results:
Snapshot creation fails

Expected results:
Snapshot creation should succeed.

Additional info:
[root@node63 ~]# gluster snap create snap10 tiervol
snapshot create: failed: Pre-validation failed on localhost. Please check log file for details
Snapshot command failed


/var/log/glusterfs/etc-glusterfs-glusterd.vol.log message:
-------------------------------------------------------------------------

[2015-11-30 17:41:14.370954] I [MSGID: 106539] [glusterd-utils.c:9145:glusterd_generate_and_set_task_id] 0-management: Generated task-id 680ca031-8e7e-4a14-ac51-9b38c7c8073b for key rebalance-id
[2015-11-30 17:41:19.412851] I [rpc-clnt.c:986:rpc_clnt_connection_init] 0-management: setting frame-timeout to 600
[2015-11-30 17:41:24.460750] E [MSGID: 106062] [glusterd-utils.c:8202:glusterd_volume_rebalance_use_rsp_dict] 0-glusterd: failed to get index
[2015-11-30 17:41:26.335639] E [MSGID: 106572] [glusterd-snapshot.c:1998:glusterd_snapshot_pause_tier] 0-management: Failed to pause tier. Errstr=(null)
[2015-11-30 17:41:26.336038] E [MSGID: 106572] [glusterd-snapshot.c:2592:glusterd_snapshot_create_prevalidate] 0-management: Failed to pause tier in snap prevalidate.
[2015-11-30 17:41:26.336217] W [MSGID: 106030] [glusterd-snapshot.c:8380:glusterd_snapshot_prevalidate] 0-management: Snapshot create pre-validation failed
[2015-11-30 17:41:26.336251] W [MSGID: 106122] [glusterd-mgmt.c:166:gd_mgmt_v3_pre_validate_fn] 0-management: Snapshot Prevalidate Failed
[2015-11-30 17:41:26.336282] E [MSGID: 106122] [glusterd-mgmt.c:820:glusterd_mgmt_v3_pre_validate] 0-management: Pre Validation failed for operation Snapshot on local node
[2015-11-30 17:41:26.336311] E [MSGID: 106122] [glusterd-mgmt.c:2164:glusterd_mgmt_v3_initiate_snap_phases] 0-management: Pre Validation Failed
[2015-11-30 17:41:26.458514] I [MSGID: 106488] [glusterd-handler.c:1463:__glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
The message "I [MSGID: 106488] [glusterd-handler.c:1463:__glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req" repeated 3 times between [2015-11-30 17:41:26.458514] and [2015-11-30 17:41:27.742935]
[2015-11-30 17:42:57.673790] I [MSGID: 106488] [glusterd-handler.c:1463:__glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2015-11-30 17:43:00.361148] I [MSGID: 106499] [glusterd-handler.c:4258:__glusterd_handle_status_volume] 0-management: Received status volume req for volume tiervol
[2015-11-30 17:42:57.784496] I [MSGID: 106488] [glusterd-handler.c:1463:__glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
Comment 2 Mohammed Rafi KC 2015-12-24 10:25:37 EST
Closing this bug as a duplicate of bug #1278798.

*** This bug has been marked as a duplicate of bug 1278798 ***

Note You need to log in before you can comment on or make changes to this bug.