Bug 1286765 - docker should not time out on sd_notify
docker should not time out on sd_notify
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 11:49 EST by Daniel Walsh
Modified: 2016-03-31 19:23 EDT (History)
13 users (show)

See Also:
Fixed In Version: docker-1.9.1-18.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286763
Environment:
Last Closed: 2016-03-31 19:23:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0536 normal SHIPPED_LIVE docker bug fix and enhancement update 2016-03-31 23:19:56 EDT

  None (edit)
Description Daniel Walsh 2015-11-30 11:49:30 EST
+++ This bug was initially created as a clone of Bug #1286763 +++

We have found several situations where docker takes a long time to start. When running in the cloud for example, docker on initial start takes a long time to created the storage on devicemapper/loopback, this is blowing up in certain situations.

When we move to docker 1.10, docker will rewrite the image labels UUID based on content in the images, this could take a huge amount of time, and should not be killed by systemd.

We need to set the timeout to 0 to allow docker all the time it needs to startup.
Comment 2 Daniel Walsh 2016-02-22 14:11:48 EST
Fixed in docker-1.10
Comment 4 Luwen Su 2016-03-18 03:22:39 EDT
In docker-1.9.1-23.el7.x86_64, the parameter in docker.service has been added with 0, TimeoutStartSec=0

move to verified
Comment 6 errata-xmlrpc 2016-03-31 19:23:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0536.html

Note You need to log in before you can comment on or make changes to this bug.