Bug 1286770 - Disk space-related error when generating CDH 5.3 images
Disk space-related error when generating CDH 5.3 images
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: sahara-image-elements (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: z3
: 7.0 (Kilo)
Assigned To: Elise Gafford
Luigi Toscano
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 11:58 EST by Luigi Toscano
Modified: 2015-12-21 12:09 EST (History)
4 users (show)

See Also:
Fixed In Version: sahara-image-elements-2015.1.0-5.el7ost
Doc Type: Bug Fix
Doc Text:
RHEL 7.2 dependency installation has grown since 7.1. This resulted in sporadic image generation failures for CDH and HDP images. With this update, the image size and the TMPFS thresholds have been increased for supported images. As a result, image generation now succeeds.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 12:09:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from failed generation (330.48 KB, text/plain)
2015-11-30 11:58 EST, Luigi Toscano
no flags Details

  None (edit)
Description Luigi Toscano 2015-11-30 11:58:23 EST
Created attachment 1100554 [details]
Log from failed generation

Description of problem:
Running the image generation of CDH 5.3 image on a RHEL 7.2 host, namely:
# sahara-disk-image-create -p cloudera

leads to an error during the installation of some packages:


--------------------

Transaction Check Error:
  installing package solr-4.4.0+cdh5.3.0+314-1.cdh5.3.0.p0.25.el6.noarch needs 68MB on the / filesystem
  installing package impala-2.1.0+cdh5.3.0+0-1.cdh5.3.0.p0.32.el6.x86_64 needs 367MB on the / filesystem
  installing package flume-ng-1.5.0+cdh5.3.0+79-1.cdh5.3.0.p0.18.el6.noarch needs 421MB on the / filesystem

Error Summary
-------------
Disk Requirements:
  At least 421MB more space needed on the / filesystem.

++ check_break after-error run_in_target bash
++ echo ''
------------------------------

The version of the script part of the currently released RHEL-OSP 7.x on RHEL 7.1 used to work, and there are no significant changes either in sahara-image-elements or in diskimage-builder.


* Please note that setting DIB_MIN_TMPFS=7 fixes the issue (as it seems to be set in the new script in RHEL-OSP8). Most likely setting DIB_NO_TMPFS=1 would work as well.


Version-Release number of selected component (if applicable):
diskimage-builder-0.1.46-4.el7ost.noarch
sahara-image-elements-2015.1.0-4.el7ost.noarch



See the complete log attached.
Comment 1 Elise Gafford 2015-11-30 16:50:53 EST
Reproduced against RHEL 7.2; RHEL 7.1 still functional without change. Will update with generous DIB_MIN_TMPFS; for now, I'll wait to do so until you're in to speak about (currently unreproducible for me) https://bugzilla.redhat.com/show_bug.cgi?id=1286719.
Comment 5 Luigi Toscano 2015-12-07 07:34:07 EST
The value of DIB_MIN_TMPFS has been set in sahara-disk-image-create to match DIB_IMAGE_SIZE and both increased (even if differently) for the two plugins.

The image can be generated on RHEL 7.2:

sahara-image-elements-2015.1.0-5.el7ost.noarch
diskimage-builder-0.1.46-4.el7ost.noarch
dib-utils-0.0.9-1.el7ost.noarch
Comment 7 errata-xmlrpc 2015-12-21 12:09:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2674

Note You need to log in before you can comment on or make changes to this bug.