Bug 1286785 - Unable to re-select full-screen guest with spice-server by mouse click when switching between dual-head display.
Unable to re-select full-screen guest with spice-server by mouse click when s...
Status: CLOSED DUPLICATE of bug 1167889
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter (Show other bugs)
7.2
All Unspecified
medium Severity medium
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks: 1298243
  Show dependency treegraph
 
Reported: 2015-11-30 13:00 EST by Ameya Charekar
Modified: 2017-03-16 12:53 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-16 12:53:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spice debug log (95.31 KB, text/plain)
2016-02-22 06:03 EST, xiaodwan
no flags Details
gtk app to reproduce the problem (3.24 KB, text/plain)
2016-02-26 05:20 EST, Pavel Grunt
no flags Details
screencast of the focus issue (3.08 MB, application/ogg)
2016-02-26 05:31 EST, Pavel Grunt
no flags Details

  None (edit)
Description Ameya Charekar 2015-11-30 13:00:09 EST
Description of problem:
In dual display, on one display guest is running in full screen mode. After working on other display when we try to enter guest by mouse click, no tab is selected and to enter guest we have to either use ALT+TAB or manually select guest tab from all available tabs from host.

Version-Release number of selected component (if applicable):
spice-server-0.12.4-15.el7.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Open full-screen guest using spice server in one display 
2. Click on other display
3. Try to enter guest by mouse click

Actual results:
No tab is selected

Expected results:
Guest (tab) should be selected

Additional info:
Works fine when using VNC server in full screen mode. Also works when running guest in maximized mode irrespective of whether using spice server or VNC server.
Comment 2 Christophe Fergeau 2016-01-14 08:59:51 EST
spice-gtk / virt-viewer versions would be useful.
Comment 3 Ameya Charekar 2016-01-14 09:29:12 EST
spice-gtk3-0.26-5.el7.x86_64
virt-viewer-2.0-6.el7.x86_64

As mentioned in additional info, this issue is reproducible using virt-viewer in full screen mode with Spice server only but it does not reproduce with virt-viewer in full screen mode with VNC server.
Comment 8 xiaodwan 2016-02-14 05:21:07 EST
I can reproduce it with rhel7.2 release version.
spice-gtk3-0.26-5.el7.x86_64
virt-viewer-2.0-6.el7.x86_64

Steps to Reproduce:
1. Prepare a spice guest, open it by virt-viewer. 
2. Move the guest display to the secondary monitor and make it to fullscreen mode.
3. Open a terminal in the guest and type some characters to make the keyboard works.
4. Move the mouse pointer to primary monitor and click the **desktop** of the primary monitor.
5. Move the mouse pointer to the secondary monitor and click the terminal in the guest.
6. Type some characters.

Actual Result:
The keyboard doesn't work.
Comment 9 xiaodwan 2016-02-14 05:24:54 EST
Additional info:
This issue doesn't occur on rhel6 or vnc client on rhel7.
Comment 10 Pavel Grunt 2016-02-22 04:03:02 EST
Hi, I think the problem is somewhere else if the app is not selected by the window manager.
Please, provide debug logs:
virt-viewer --debug --spice-debug

Thanks
Comment 11 xiaodwan 2016-02-22 06:03 EST
Created attachment 1129233 [details]
spice debug log
Comment 12 Pavel Grunt 2016-02-26 05:20 EST
Created attachment 1130808 [details]
gtk app to reproduce the problem

Simple gtk program to reproduce the issue. It works similar as spice-gtk widget.
Comment 13 Pavel Grunt 2016-02-26 05:26:31 EST
I was able to reproduce the problem using a simple gtk program - please see attachment.

In full-screen mode it stops receiving focus in events after a while. And a window which is below the full-screen window will get focus instead.

rpm -q gtk3
gtk3-3.14.13-16.el7.x86_64

Reassigning to gtk for investigation
Comment 14 Pavel Grunt 2016-02-26 05:31 EST
Created attachment 1130811 [details]
screencast of the focus issue

Screencast for the comment 13.

After 30s the "fullscreen program" stopped receiving focus events when clicking on it. Nautilus window which was below it got focus instead.
Comment 16 Jonathon Jongsma 2016-03-17 16:24:33 EDT
This looks very similar to Bug 1167889. (by the way, I re-assigned that one to mutter since I assumed it was the window manager's responsibility)
Comment 17 Matthias Clasen 2016-05-18 11:51:48 EDT
What makes you think that this is a gtk issue ?
Comment 18 Matthias Clasen 2016-05-18 11:56:45 EDT
Moving to mutter, which seems more likely to be responsible.
Comment 19 Florian Müllner 2016-05-19 12:51:52 EDT
(In reply to Jonathon Jongsma from comment #16)
> This looks very similar to Bug 1167889.

This may indeed be the same issue. Unfortunately I don't have a non-VM RHEL system at hand for testing, so it'd be appreciated if someone could test whether the issue is reproducible with mutter-3.14.4-21.el7.
Comment 22 xiaodwan 2016-05-20 08:26:40 EDT
1. I can't reproduce it by only upgrading clutter and mutter.

2. And i found keep clutter and mutter as old version, then only upgrade spice-* to latest version, and cannot reproduce it either.

$ rpm -qa | grep spice
spice-glib-0.31-2.el7.x86_64
spice-gtk-0.31-2.el7.x86_64
spice-server-0.12.4-17.el7.x86_64
spice-protocol-0.12.11-1.el7.noarch
spice-vdagent-0.14.0-10.el7.x86_64
spice-gtk3-0.31-2.el7.x86_64
Comment 24 Florian Müllner 2017-03-14 15:49:40 EDT
Comment #22 suggests that this issue is no longer reproducible in RHEL 7.3. Is this the case?
Comment 26 Florian Müllner 2017-03-16 12:53:13 EDT
Thank you for the confirmation. I'll close the issue as a duplicate then, please re-open if the customer experience the problem again on RHEL 7.3.

*** This bug has been marked as a duplicate of bug 1167889 ***

Note You need to log in before you can comment on or make changes to this bug.