Bug 1286788 - Provision Requests for VM quota validation remains in pending approval state.
Provision Requests for VM quota validation remains in pending approval state.
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Tina Fitzgerald
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 13:01 EST by Aziza Karol
Modified: 2015-12-03 23:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-03 23:43:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snpshot (71.30 KB, image/png)
2015-11-30 13:01 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-11-30 13:01:52 EST
Created attachment 1100574 [details]
snpshot

Description of problem:


Version-Release number of selected component (if applicable):
5.5.0.12-rc2.20151124135609_653c0d4 

How reproducible:
100%

Steps to Reproduce:
1.set tenant quota for Allocated Number of Virtual Machines.
2.provision a VM with higher no. of VM value then the values set for tenant quota
3.

Actual results:
Request does not get auto approved and remains in pending approval state if vm quota exceeded.see attached screenshot. 
Also  "###" gets added at the end of VM name.check description in screenshot

Expected results:
Request should get auto approved and quota exceeded message should be displayed

Additional info:
Comment 2 Tina Fitzgerald 2015-11-30 15:47:47 EST
Hi Aziza,

Can I access your test environment?

Thanks,
Tina
Comment 4 Tina Fitzgerald 2015-12-01 11:21:44 EST
Hi Aziza,

The Qota domain service quota_source method was set to use group instead of the default source of tenant. I'm not sure if this is the same environment as the other day and if so, I might have changed that in your environment for testing purposes.

I changed the quota_source method back to tenant and copied your provision request 19 and provisioned again(req 20). The provision completed without error and didn't try to do quota because there were no limits set(as shown below)

([miq_provision_request_20]) <AEMethod limits> Getting Tenant Quota Values for: {}
([miq_provision_request_20]) <AEMethod limits> No Quota limits set. No quota check being done.
 
Can we change this ticket to be for group quota backward compatibility? 
I see an issue there in the limits quota method:

ERROR -- : Q-task_id([miq_provision_request_19]) <AEMethod limits> The following error occurred during method evaluation:
ERROR -- : Q-task_id([miq_provision_request_19]) <AEMethod limits>   NameError: undefined local variable or method `quota_max' for main:Object

Let me know if you have any questions.

Thanks,
Tina
Comment 5 Tina Fitzgerald 2015-12-01 11:40:47 EST
Maybe this ticket can be closed because the following issue describes the problem?
https://bugzilla.redhat.com/show_bug.cgi?id=1286999
Comment 7 Tina Fitzgerald 2015-12-03 15:06:19 EST
Hi Aziza,

Vm provisioning has auto-approval set for 1 VM. Requesting more than the single VM needs be manually approved. I approved the request id 2 in your test environment and the request was denied due to quota. This is working as designed.

Can we close this ticket?

Thanks,
Tina
Comment 8 Aziza Karol 2015-12-03 23:43:59 EST
Thanks Tina for the Info.I will close the ticket.

Note You need to log in before you can comment on or make changes to this bug.