Bug 1286798 - [Docs] [Director] Document update procedure from OSP7 or OPS7y2 to 7.2
[Docs] [Director] Document update procedure from OSP7 or OPS7y2 to 7.2
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Dan Macpherson
Radek Bíba
: Documentation
: 1267318 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 13:30 EST by James Slagle
Modified: 2016-03-15 23:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 23:27:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slagle 2015-11-30 13:30:49 EST
We need to document the update procedure from OSP 7 or 7y1 to 7y2.

I've started an etherpad which can serve as the draft documentation:
http://openstack.etherpad.corp.redhat.com/osp-d-update-kbase
Comment 2 James Slagle 2015-11-30 13:32:55 EST
The contents of the etherpad could still change somewhat, but the overall flow and stucture should remain stable at this point.

Let me know the best way to handle this process. We could save revisions to the etherpad or update this bz when the content changes, etc.
Comment 3 Andrew Dahms 2015-12-07 17:59:50 EST
Assigning to Dan for review.
Comment 7 Giulio Fidente 2015-12-16 07:19:25 EST
hi Dan, I think it looks great. I have some comments:

1. in section 9.3.4, the inclusion of /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-vip.yaml for people upgrading is not needed when using an external balancer (like the next bullet for control_virtual_ip replacement)

2. the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1290826 is going to need another paragraph in 9.3.4:

  when upgrading from 7.0 and if using a single network for the overcloud (the original deployment did not include network-isolation.yaml) then include the following environment file in the update command

    /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-publicvip-on-ctlplane.yaml

3. in section 9.3.5, in the list of environments to be provided, after "Any network isolation files, including the initialization file" I think we might add a note saying "The external-loadbalancer-vip.yaml in case you're using an external load balancer"

4. in sections 9.3.5, in the list of environments, I would replace "Any version-specific environment files" and "Any storage environment files." with "The version-specific environment files if needed" and "The storage environment file storage-environment.yaml if you were using it"; this is important because *customizations* of any kind should go last

5. in section 9.3.5 the sample includes /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-keystone-admin-internal-api.yaml but that is *not* needed when updating from 7.1
Comment 8 Ofer Blaut 2015-12-17 03:41:11 EST
Adding bug https://bugzilla.redhat.com/show_bug.cgi?id=1292035 to be added to the docs
Comment 9 Dan Macpherson 2015-12-17 20:28:58 EST
*** Bug 1267318 has been marked as a duplicate of this bug. ***
Comment 10 Dan Macpherson 2016-01-27 23:29:17 EST
Hi Guilio,

I think I've got everything from comment#7 added:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Updating_the_Overcloud.html#sect-Version_Specific_Notes

Was there anything else I needed to add to this section?
Comment 11 Giulio Fidente 2016-01-29 07:00:50 EST
hi Dan, looks good except in 9.3.4, where you say to include:

  /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-publicvip-on-ctlplane.yaml

the filename appears on a black background but it is not a command so it probably shouldn't, thanks!

Note You need to log in before you can comment on or make changes to this bug.