Bug 1286810 - Log out from userportal doesn't work for non-admins
Log out from userportal doesn't work for non-admins
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: AAA (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Ravi Nori
Petr Kubica
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 14:05 EST by jniederm
Modified: 2016-07-05 03:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:46:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
masayag: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49470 master MERGED engine : Log out from userportal doesn't work for non-admins Never

  None (edit)
Description jniederm 2015-11-30 14:05:03 EST
Description of problem:
'http://localhost:8080/ovirt-engine/' is loaded after logging out from userportal. Sign in upper right corner says 'Not Logger In'. However link 'User Portal' actually leads back to userportal instead to the logging form.

Version-Release number of selected component (if applicable):
4.0 master, commit 7ec4da8

How reproducible:
100%

Steps to Reproduce:
1. Log-in to userportal as non-admin user (I used aaa-jdbc with separate, non-internal profile)
2. Log out from userportal
3. Click on 'User Portal' link in welcome page

Actual results:
Userportal is loaded, the user seems to be still logged in

Expected results:
Login from is show
Comment 1 Red Hat Bugzilla Rules Engine 2015-12-01 01:06:03 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 2 Petr Kubica 2016-06-15 06:30:23 EDT
Verified in 4.1.0-0.0.master.20160614231313.git26c6df3.el7.centos
Comment 3 Sandro Bonazzola 2016-07-05 03:46:46 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.