Bug 1286817 - using neutron with ovs native depends on ryu and it's not installed by openstack-neutron
using neutron with ovs native depends on ryu and it's not installed by openst...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Ihar Hrachyshka
Ofer Blaut
:
Depends On: 1287120
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 14:15 EST by Arie Bregman
Modified: 2016-04-26 14:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 09:31:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arie Bregman 2015-11-30 14:15:37 EST
Description of problem:
Since Liberty/RHOS-8, ovs agent can use native interface which using Ryu.
But Ryu is not part of openstack-neutron dependencies and it isn't installed by it, which leads to errors when using ovs native.
 
Version-Release number of selected component (if applicable): 8.0

Steps to Reproduce:
1. install openstack-neutron
2. clone neutron repo
3. cd neutron && truncate --size 0 requirements.txt && truncate --size 0 test-requirements.txt;
6. tox --sitepackages -e dsvm-functional neutron.tests.functional.agent.test_ovs_flows.ARPSpoofNativeTestCase.test_arp_spoof_blocks_request(vsctl)

Actual results:
from ryu.base import app_manager,
ImportError: No module named ryu.base

Expected results:
test ran successfully :)
Comment 2 Ihar Hrachyshka 2015-12-01 08:11:36 EST
python-ryu package is not included in Fedora repos. There is a COPR with the package from Arie: http://copr-dist-git.fedorainfracloud.org/cgit/abregman/el7-rhos8-test-deps/python-ryu.git/tree/python-ryu.spec
Comment 3 Ihar Hrachyshka 2015-12-02 09:41:15 EST
Fedora review for the package: https://bugzilla.redhat.com/show_bug.cgi?id=1287120
Comment 4 Assaf Muller 2015-12-15 12:56:13 EST
About blocker flag, the native ovsdb implementation is not turned on by default (The CLI one is). I'm not sure if the criteria for blocker bugs includes issues with non-default features?
Comment 5 Nir Yechiel 2015-12-16 04:32:09 EST
(In reply to Assaf Muller from comment #4)
> About blocker flag, the native ovsdb implementation is not turned on by
> default (The CLI one is). I'm not sure if the criteria for blocker bugs
> includes issues with non-default features?

Agree. We should still target this for GA though, and make sure to document this in case it doesn't make it on time.
Comment 6 Arie Bregman 2016-01-07 09:31:18 EST
Package available and added as a requirement in openstack-neutron spec.

https://review.gerrithub.io/#/c/256223

Note You need to log in before you can comment on or make changes to this bug.