This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286856 - sahara-image-elements for 8.0 requires epoch
sahara-image-elements for 8.0 requires epoch
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: sahara-image-elements (Show other bugs)
8.0 (Liberty)
All Linux
unspecified Severity high
: beta
: 8.0 (Liberty)
Assigned To: Elise Gafford
Luigi Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 17:08 EST by Elise Gafford
Modified: 2016-04-07 17:15 EDT (History)
5 users (show)

See Also:
Fixed In Version: sahara-image-elements-3.0.0-3.el7ost
Doc Type: Bug Fix
Doc Text:
In the Liberty release, the OpenStack versioning scheme is now based on the major release number (previously, it was based on year). This update adds an epoch to the current sahara-image-elements package to ensure that it upgrades the older version.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:15:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elise Gafford 2015-11-30 17:08:14 EST
Description of problem: Current sahara-image-elements package for 8.0 does not upgrade sahara-image-elements for 7.0 due to versioning scheme changes.


Version-Release number of selected component (if applicable):
sahara-image-elements-3.0.0-2


How reproducible:
100%

Steps to Reproduce:
1. Install sahara-image-elements-2015.1.0-4
2. Attempt to install sahara-image-elements-3.0.0-2

Actual results:
Package manager notes that package does not update currently installed version.

Expected results:
Package manager installs new (Liberty-based) package.
Comment 4 Luigi Toscano 2016-01-08 05:01:06 EST
Epoch correctly added:
1:sahara-image-elements-3.0.0-3.el7ost.noarch
Comment 5 errata-xmlrpc 2016-04-07 17:15:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.