Bug 1286858 - [DOCS] What is the region infra for?
[DOCS] What is the region infra for?
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ashley Hardin
Eric Jones
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 17:33 EST by Eric Jones
Modified: 2016-04-06 10:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 10:56:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2015-11-30 17:33:34 EST
Document URL: 
https://access.redhat.com/documentation/en/openshift-enterprise/version-3.1/installation-and-configuration/#configuring-ansible

Section Number and Name: 
2.4.3 Configuring Ansible

Describe the issue: 
All of the example masters for setting up the /etc/ansible/hosts file put the master into the region infra, but this is never used.

Suggestions for improvement: 
Use it in other examples, like putting certain pods into that region, or at least explain the label.

Additional information: 
I have seen plenty of customers that copy and paste our examples, only changing the relevant information, which leads to their master being in the infra region for, seemingly, no reason.
Comment 1 Brenton Leanhardt 2016-03-21 16:49:58 EDT
For Docs,

The general idea is for Nodes to have a label that signifies the router and registry should be installed on them:

https://github.com/openshift/openshift-ansible/blob/master/inventory/byo/hosts.ose.example#L153

Nodes created with a label that matches the setting in that example inventory and ansible is run the default router and registry will be automatically deployed.

The default label is 'region=infra'.  In all other aspects they are normal Nodes though.  They only have the special label since we've found many customers prefer to have the router and registry on specific hosts.  This can due to how they are loadbalancing the router or how they want to maintain their Nodes.  For example, not all Nodes are running containers that are mission critical.  While a Node labeled "dev" might be rebooted or deleted at any time, the "infra" Nodes should be treated with the same care as the rest of the OpenShift infrastructure.
Comment 2 Ashley Hardin 2016-03-22 16:20:16 EDT
Work in progress:
https://github.com/openshift/openshift-docs/pull/1797
Comment 3 Ashley Hardin 2016-03-31 10:35:51 EDT
Approved by Eric Jones.
Comment 4 openshift-github-bot 2016-03-31 10:36:17 EDT
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/3c9339a0c945a4c2a9485e28fa11cc3daf9b2005
Bug 1286858, Documented the infra region

https://github.com/openshift/openshift-docs/commit/76d8b72ae2ff9c5ae53feafb2eb4a0de366aba76
Merge pull request #1797 from ahardin-rh/infra-region

Bug 1286858, Documented the infra region

Note You need to log in before you can comment on or make changes to this bug.