Bug 128688 - RPM db4 error(-30978) while installing on motherboard ASUS P4B with Pentium 1,6 GHz
RPM db4 error(-30978) while installing on motherboard ASUS P4B with Pentium 1...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-27 20:36 EDT by Edgar Hoch
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/anaconda-ks.cfg created by the installation process. (2.34 KB, text/plain)
2004-07-27 20:53 EDT, Edgar Hoch
no flags Details
Log files from /tmp after the crash of anaconda while installing FC3 (174.91 KB, application/octet-stream)
2005-03-04 16:52 EST, Edgar Hoch
no flags Details

  None (edit)
Description Edgar Hoch 2004-07-27 20:36:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1)
Gecko/20020920 Netscape/7.0

Description of problem:
When I try to install FC2 on two of our PCs then the rpm database
seems to becomes corrupted somewhere while the package installation.
In the file /root/install.log I found many messages of the form:

error: db4 error(-30978) from dbcursor->c_put: DB_RUNRECOVERY: Fatal
error, run database recovery
error: error(-30978) storing record /usr/share/locale/cy/LC_MESSAGES/
into Dirnames

These messages are repeated with different paths many times, starting
somewhere in the middle of the file /root/install.log and lasting
until the last rpm package is installed. There are still messages
between the error messages that a rpm package with name xxx will be
installed, but starting with the error messages these packages are not
installed afterwards.

In my case the error messages start after the message
GConf2-2.6.0-4.i386 wird installiert.
(german - the named package is being installed)
This is reproducable when using the same (kickstart) configuration.
But I suspect that it has nothing to do with the package itself,
but that it seems that is a general problem with some driver or
something like that.

This error appears only on two of our hosts, which have the same
hardware configuration. They have a motherboard ASUS P4B with bios
version 1012, cpu Pentium 4 with 1,6 GHz, 512 mb ram, scsi hard disk .
On both computers the results are the same. I exchanged the hard disk
and the memory module, with and without ECC, but the results are the
same. memtest86+ reported no error on both computers.

I installed FC2 on about 18 other computers with many different
motherboards and different intel cpus, using the same source (booting
from cd, kickstart installation over the dhcp, FC2 sources over nfs).
While installing the same set of rpm packages, none of them had these
problems. Only these two computers with equal hardware.

First I thought this would be a hardware error, after some days and
some tests with different hardware components and the same results on
both equal hosts and very reproducable results I tend to say that it
may be a software problem.

Does someone have an idea what the reason could be and what to do to
install FC2 successful on that hardware?

Many thanks in advance!


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Use the kickstart file and install FC2 on a PC with ASUS P4B
motherboard and Intel Pentium 4 1,6 GHz.


Actual Results:  After FC2 installation has finished and rebooted the
graphical X11 login will not appear. There appear messages from init
that 'x' entry is respawning to often and will be suspended for 5 minutes.
In /root/install.log there will be the messages noted above.
Some rpm packages seems not being installed.

Expected Results:  FC2 installation should be successful like on our
other computers.

Additional info:
Comment 1 Edgar Hoch 2004-07-27 20:53:19 EDT
Created attachment 102241 [details]
/root/anaconda-ks.cfg created by the installation process.

I have blanked out the host names and ip addresses for security reasons.
Comment 2 Jeremy Katz 2004-08-02 20:30:48 EDT
Can you verify your media following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?
Comment 3 Jeremy Katz 2004-10-07 15:01:13 EDT
Closing due to inactivity.  Please reopen if you have further
information to add to this report.
Comment 4 Edgar Hoch 2005-03-04 16:47:05 EST
I tried FC3 on the same computer as noted above. Its a Intel Pentium 1,6 GHz
with motherboard ASUS P4B BIOS version 1012 (and I also tried BIOS version
1013-004 beta).

This time FC3 installation crashes with a window from anaconda telling me
that there seems to be a bug and I should report it as an anaconda error
through bugzilla. I will put an attachment gziped tar file of some log files
from the installation from /tmp.

I have edited the log files to hide private information. All IP numbers and
host names are replaced by some 'x'.

Is there a chance to get this working?
I have problems with this computer since RedHat 9 (RedHat 7.2 was working).
The problem was similar in all newer versions.

I testet the memory with memtest86, verified the hard disk with the
verify option build in to the SCSI controller - no errors.
I am booting with CD FC3 disk 1 and starting with 'linux ks'.
The computer uses dhcp and nfs to access the FC3 installation image.
I created the image from the iso image by mounting the image without
creation of a CD and then copying the data from each CD image to disk.
I installed several computers with the same FC3 image and had no problem with it.

Just do mention: The error message is reproduceable - each time the same (when
using the same parameters).

This problem seems to be very mysterious to me!

Many thanks in advance!

Edgar
Comment 5 Edgar Hoch 2005-03-04 16:52:06 EST
Created attachment 111681 [details]
Log files from /tmp after the crash of anaconda while installing FC3
Comment 6 Jeremy Katz 2005-09-21 16:51:19 EDT
This has been shown to be due to cpus with incorrect microcode.  A BIOS upgrade
to flash the microcode should fix the proble

Note You need to log in before you can comment on or make changes to this bug.