This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286891 - [userinterface_public_501]Unable to delete specific buildconfig and deploymentconfig on web console
[userinterface_public_501]Unable to delete specific buildconfig and deploymen...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 22:12 EST by yapei
Modified: 2015-12-02 11:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 11:22:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
BuildConfig-CannotDelete (320.17 KB, image/png)
2015-11-30 22:15 EST, yapei
no flags Details
DeploymentConfig-CannotDelete (320.45 KB, image/png)
2015-11-30 22:15 EST, yapei
no flags Details

  None (edit)
Description yapei 2015-11-30 22:12:29 EST
Description of problem:
On builds(/console/project/test/browse/builds/<bc>) and deployments(/console/project/test/browse/deployments/<dc>) page, clicking on Delete button didn't take effect.Although alert message displayed, buildconfigs and deploymentconfigs still shown on page

Version-Release number of selected component (if applicable):
devenv-rhel7_2838
oc v1.1-262-g429d52e
kubernetes v1.1.0-origin-1107-g4c8e6f4

How reproducible:
Always

Steps to Reproduce:
1.Create image stream
2.Create application with ruby image and source code 
3.Delete buildconfig and deploymentconfig

Actual results:
3. buildconfig and deploymentconfig still shown on page, see attachments

Expected results:
3.specific buildconfig and deploymentconfig should be deleted

Additional info:
imagestreams,services,pods could be deleted successfully
Comment 1 yapei 2015-11-30 22:15 EST
Created attachment 1100707 [details]
BuildConfig-CannotDelete
Comment 2 yapei 2015-11-30 22:15 EST
Created attachment 1100708 [details]
DeploymentConfig-CannotDelete
Comment 3 Samuel Padgett 2015-12-01 14:58:25 EST
I think this is working as intended, although admittedly is a little confusing. We show the deleted build config (with a warning) so you can see old builds associated with it. The builds themselves aren't deleted, just the config. You should see the same behavior if you delete the build config (with --cascade=false) on the command line.

Jessica, can you confirm?

We have a trello card to support cascading deletes, which the CLI defaults to. Right now, that's not supported in the UI.
Comment 4 Jessica Forrester 2015-12-02 11:22:34 EST
Yes this is working.  The buildconfig object has been deleted, we still show you the build exists and the buildconfig that created it no longer exists so that you know to clean up the old builds. As sam says this is because we don't support cascading delete yet in web console.

Note You need to log in before you can comment on or make changes to this bug.