Bug 1286892 - discrete graphics card on hybrid graphics system not working with kernel 4.2.6-301 [NEEDINFO]
discrete graphics card on hybrid graphics system not working with kernel 4.2....
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 22:18 EST by Jonathan
Modified: 2016-10-26 12:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-26 12:55:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
labbott: needinfo? (emailjonathananderson-fedora)


Attachments (Terms of Use)

  None (edit)
Description Jonathan 2015-11-30 22:18:04 EST
Description of problem:
optirun exits with error error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

Version-Release number of selected component (if applicable):
4.2.6-301

How reproducible:
Always

Steps to Reproduce:
1. start optirun
2.
3.

Actual results:
fails with above mentioned error

Expected results:
runs.

Additional info:
It runs without errors with kernel 4.2.6-300
Comment 1 Josh Boyer 2015-12-01 07:30:06 EST
Are you using bumblebee or the nvidia driver?
Comment 2 Justin M. Forbes 2015-12-01 10:10:39 EST
This is interesting as there were no patches that would impact this area between 4.2.6-300 and 301 that I can see.  Does this currently work with the 300 kernel, or was it working before you updated to 301 and not tested since?
Comment 3 Jonathan 2015-12-01 11:37:43 EST
Good question, I think I installed the proprietary nvidia to get to CUDA, but I think bumblebee runs as well. I need more help to answer your question.

dnf list installed \*kernel\*:

Installed Packages
kernel.x86_64          4.2.6-300.fc23
kernel.x86_64          4.2.6-301.fc23
kernel-core.x86_64     4.2.6-300.fc23
kernel-core.x86_64     4.2.6-301.fc23
kernel-devel.x86_64    4.2.6-300.fc23
kernel-devel.x86_64    4.2.6-301.fc23
kernel-headers.x86_64  4.2.6-301.fc23
kernel-modules.x86_64  4.2.6-200.fc22                           
kernel-modules.x86_64  4.2.6-300.fc23                      
kernel-modules.x86_64  4.2.6-301.fc23

uname -r :4.2.6-300.fc23.x86_64
optirun glxspheres: 
Context is Direct
OpenGL Renderer: GeForce GT 750M/PCIe/SSE2
76.655344 frames/sec - 85.547364 Mpixels/sec
Comment 4 Jonathan 2015-12-01 11:40:45 EST
uname -r: 4.2.6-301.fc23.x86_64

optirun glxspheres
[   59.990402] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

[   59.990431] [ERROR]Aborting because fallback start is disabled.
Comment 5 Jonathan 2015-12-02 02:00:19 EST
This turned interesting.
I just got the same error for kernel 300 after suspend - resume. Now it's not working there either.
I did a few tests before I dared to post this bug and optirun never worked for kernel 301, and always worked immediately after boot on kernel 300.
Optirun worked fine with kernel 300 before suspend. Now it's not working.

Anyone got ideas about what to look for?
Comment 6 Jonathan 2015-12-02 02:12:37 EST
journalctl:

Dec 02 08:06:46 jenna kernel: bbswitch: enabling discrete graphics
Dec 02 08:06:46 jenna bumblebeed[1216]: [27398.955151] [ERROR]Could not enable discrete graphics card
Dec 02 08:06:46 jenna kernel: nvidia 0000:01:00.0: Refused to change power state, currently in D3
Comment 7 Jonathan 2015-12-02 02:19:01 EST
After reboot, it went back to normal i.e. immediately after boot, optirun works for kernel 300, does not work for kernel 301.
Comment 8 Laura Abbott 2016-09-23 15:46:17 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 9 Laura Abbott 2016-10-26 12:55:17 EDT
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 4 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.

Note You need to log in before you can comment on or make changes to this bug.