Bug 1286916 - prevent gluster brick creation on mbr partitions
prevent gluster brick creation on mbr partitions
Status: CLOSED DUPLICATE of bug 1230338
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
3.1
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: Shubhendu Tripathi
RHS-C QE
gluster
:
Depends On: 1211140
Blocks: 1230338
  Show dependency treegraph
 
Reported: 2015-12-01 00:49 EST by Ramesh N
Modified: 2015-12-01 00:53 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1211140
Environment:
Last Closed: 2015-12-01 00:53:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh N 2015-12-01 00:49:14 EST
+++ This bug was initially created as a clone of Bug #1211140 +++

+++ This bug was initially created as a clone of Bug #1210841 +++

Description of problem:
Extended partition is shown as available for bricks creation, however when someone wants to create a brick on such partition it fails with unexpected exception.

Version-Release number of selected component (if applicable):
ovirt-engine-3.6.0-0.0

How reproducible:
100%

Steps to Reproduce:
1. Create some extended partition on host
2. Go to 'Storage Device' tab check availability of the partition and try to create a brick on it


Actual results:
Unexpected exception

Expected results:
The partition should not be available it should be shown with a lock or add some functionality which creates a proper logical partition first.

Additional info:

--- Additional comment from Lubos Trilety on 2015-04-10 12:59:07 EDT ---

Such partition stays to be shown as available even when it is completely used.

--- Additional comment from Sahina Bose on 2015-04-20 03:05:20 EDT ---

Marking it as low priority as extended partition is not a common use case for gluster.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-10-19 07:02:59 EDT ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

--- Additional comment from Martin Bukatovic on 2015-10-19 11:56:49 EDT ---

To align with BZ 1270792, I would propose to disallow admin to create brick on
extended partition.

--- Additional comment from Sandro Bonazzola on 2015-10-26 08:47:49 EDT ---

this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high

--- Additional comment from Sandro Bonazzola on 2015-11-05 03:20:30 EST ---

oVirt 3.6.0 has been released on November 4th, re-targeting to 4.0 since this bug has been marked with severity < high

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-16 09:07:45 EST ---

This bug is flagged for 3.6, yet the milestone is for 4.0 version, therefore the milestone has been reset.
Please set the correct milestone or add the flag.

--- Additional comment from Ramesh N on 2015-12-01 00:47:17 EST ---

(In reply to Martin Bukatovic from comment #3)
> To align with BZ 1270792, I would propose to disallow admin to create brick
> on
> extended partition.

Brick creation should be blocked on any partitions not just extended partition. Changing the bug description accordingly.
Comment 2 Ramesh N 2015-12-01 00:53:23 EST

*** This bug has been marked as a duplicate of bug 1230338 ***

Note You need to log in before you can comment on or make changes to this bug.