Bug 1286927 - Tier: ec xattrs are set on a newly created file present in the non-ec hot tier
Tier: ec xattrs are set on a newly created file present in the non-ec hot tier
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: disperse (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Pranith Kumar K
Bhaskarakiran
: ZStream
Depends On: 1286910 1286985
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-12-01 01:10 EST by Nithya Balachandran
Modified: 2016-11-23 18:12 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286910
Environment:
Last Closed: 2016-03-01 01:00:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0193 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 update 2 2016-03-01 05:20:36 EST

  None (edit)
Description Nithya Balachandran 2015-12-01 01:10:30 EST
+++ This bug was initially created as a clone of Bug #1286910 +++

Description of problem:
A newly created file on a tiered volume with distributed-disperse cold tier and dist-rep hot tier has EC xattrs set on it even though it exists on a hot tier.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Create a distributed-disperse (2x(4+2)) volume and attach a dist-rep hot tier to it
2. Start the volume and FUSE mount it.
3. Create a file on the mount point. Internally, tier first creates a linkto file on the cold tier and then creates the actual data file on the hot tier.
4. Check the xattrs set on the file on the hot tier bricks

Actual results:
The file has EC xattrs set on it

Expected results:
No EC xattrs should be present on files in non-EC subvols

Additional info:
Comment 5 Bhaskarakiran 2015-12-15 04:09:40 EST
The ec attrs are no longer set on the hot tier which is a dist-rep vol. Marking this as fixed.

[root@tettnang ~]# getfattr -d -e hex -m. /rhs/brick2/dv1-*/testfile
getfattr: Removing leading '/' from absolute path names
# file: rhs/brick2/dv1-2/testfile
security.selinux=0x73797374656d5f753a6f626a6563745f723a756e6c6162656c65645f743a733000
trusted.bit-rot.version=0x0200000000000000566fd85e000b78e3
trusted.gfid=0xb3934c2bbb494b8d975895c6274ad90f
trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri.1=0x000000000d8000000000000000000001
trusted.pgfid.00000000-0000-0000-0000-000000000001=0x00000001

[root@tettnang ~]# gluster v info disperse_vol1
 
Volume Name: disperse_vol1
Type: Tier
Volume ID: a6f27d4d-6838-47bf-ba2d-43fe9c980be3
Status: Started
Number of Bricks: 14
Transport-type: tcp
Hot Tier :
Hot Tier Type : Distribute
Number of Bricks: 2
Brick1: tettnang:/rhs/brick2/dv1-2
Brick2: tettnang:/rhs/brick2/dv1-1
Cold Tier:
Cold Tier Type : Distributed-Disperse
Number of Bricks: 2 x (4 + 2) = 12
Brick3: transformers:/rhs/brick1/b1
Brick4: interstellar:/rhs/brick1/b2
Brick5: transformers:/rhs/brick2/b3
Brick6: interstellar:/rhs/brick2/b4
Brick7: transformers:/rhs/brick3/b5
Brick8: interstellar:/rhs/brick3/b6
Brick9: transformers:/rhs/brick4/b7
Brick10: interstellar:/rhs/brick4/b8
Brick11: transformers:/rhs/brick5/b9
Brick12: interstellar:/rhs/brick5/b10
Brick13: transformers:/rhs/brick6/b11
Brick14: interstellar:/rhs/brick6/b12
Options Reconfigured:
cluster.tier-mode: cache
features.ctr-enabled: on
performance.readdir-ahead: on
features.uss: on
features.quota: on
features.inode-quota: on
features.quota-deem-statfs: on
client.event-threads: 2
server.event-threads: 2
cluster.watermark-low: 1
cluster.watermark-hi: 2
[root@tettnang ~]#
Comment 7 errata-xmlrpc 2016-03-01 01:00:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.