Bug 1286976 - Add "terminate" action for cloud instance [NEEDINFO]
Add "terminate" action for cloud instance
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.0.1
x86_64 Linux
high Severity high
: GA
: 5.6.0
Assigned To: Tim Wade
Taras Lehinevych
:
Depends On:
Blocks: 1290196
  Show dependency treegraph
 
Reported: 2015-12-01 04:34 EST by Prasad Mukhedkar
Modified: 2016-06-29 11:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290196 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:14:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pmukhedk: needinfo? (jhardy)


Attachments (Terms of Use)

  None (edit)
Description Prasad Mukhedkar 2015-12-01 04:34:06 EST
Description of problem:

Through cloudforms dashboard it is possible to terminate an instance 
running on AWS Cloud Provider. "Instance > Power > Terminate". However,
This action is not exposed in Cloudfroms RESTAPI. 

In order to integrate cloudfroms with external IT Process application
and manage complete life cycle of instances. This action is very much
necessary
Comment 2 John Hardy 2015-12-10 04:42:02 EST
There is a simple workaround here, that is create automate that vm.stop and call from rest api  as custom automation.
Comment 4 Tim Wade 2016-01-06 12:21:02 EST
PR: https://github.com/ManageIQ/manageiq/pull/5807
Comment 5 Taras Lehinevych 2016-05-13 07:52:46 EDT
Verified in 5.6.0.6-beta2.5
Comment 7 errata-xmlrpc 2016-06-29 11:14:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.