Bug 1286988 - bitrot: gluster man page and gluster cli usage does not mention the new scrub status cmd
bitrot: gluster man page and gluster cli usage does not mention the new scrub...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: bitrot (Show other bugs)
mainline
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Kotresh HR
bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 04:52 EST by Kotresh HR
Modified: 2016-06-16 09:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:47:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kotresh HR 2015-12-01 04:52:44 EST
Description of problem:
gluster man page and gluster cli usage does not mention the new scrub status cmd

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
$gluster volume bitrot
Usage: volume bitrot <VOLNAME> {enable|disable} |
volume bitrot <volname> scrub-throttle {lazy|normal|aggressive} |
volume bitrot <volname> scrub-frequency {hourly|daily|weekly|biweekly|monthly} |
volume bitrot <volname> scrub {pause|resume|status}


Expected results:
root@fedora2:$gluster volume bitrot
Usage: volume bitrot <VOLNAME> {enable|disable} |
volume bitrot <volname> scrub-throttle {lazy|normal|aggressive} |
volume bitrot <volname> scrub-frequency {hourly|daily|weekly|biweekly|monthly} |
volume bitrot <volname> scrub {pause|resume|status} |
volume bitrot <volname> scrub status

And similarly "man gluster" should also show "volume bitrot <volname> scrub status" under 'Bitrot Commands' section.

Additional info:
Comment 1 Vijay Bellur 2015-12-01 04:59:23 EST
REVIEW: http://review.gluster.org/12834 (bitrot: Update 'scrub status' cmd in man page) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 2 Vijay Bellur 2015-12-01 06:39:35 EST
REVIEW: http://review.gluster.org/12834 (bitrot: Update 'scrub status' cmd in man page) posted (#2) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 3 Vijay Bellur 2015-12-09 08:00:43 EST
REVIEW: http://review.gluster.org/12834 (bitrot: Update 'scrub status' cmd in man page) posted (#3) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 4 Vijay Bellur 2015-12-11 00:02:49 EST
REVIEW: http://review.gluster.org/12834 (bitrot: Update 'scrub status' cmd in man page) posted (#4) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 5 Vijay Bellur 2015-12-14 06:37:09 EST
COMMIT: http://review.gluster.org/12834 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 0598ca33ec95b4f4c44582c6154c52494b910b3a
Author: Kotresh HR <khiremat@redhat.com>
Date:   Tue Dec 1 15:24:11 2015 +0530

    bitrot: Update 'scrub status' cmd in man page
    
    Update following bitrot status command in man page.
    gluster vol bitrot <volname> scrub status
    
    Change-Id: I86aa123d568711c6b3d655b60cfd901a8d4c3408
    BUG: 1286988
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12834
    Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 6 Niels de Vos 2016-06-16 09:47:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.