This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286993 - cat /sys/class/net/tun0/speed -> 10: that is wrong
cat /sys/class/net/tun0/speed -> 10: that is wrong
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 05:07 EST by Harald Reindl
Modified: 2017-04-11 11:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-11 11:03:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 68581 None None None 2017-04-11 11:03 EDT

  None (edit)
Description Harald Reindl 2015-12-01 05:07:37 EST
TAN/TUP devices are reported as 10 Mbit which results in https://bugzilla.redhat.com/show_bug.cgi?id=1286792 and is plain wrong, the bandwidth is limited by the physical connection behind the tunnel and can't be detected that easily if it comes to bridges and forwarding-rules

however, 10 Mbit is not true and has side-effects like with vnstat

$ cat /sys/class/net/tun0/speed 
10

[root@srv-rhsoft:~]$ cat /sys/class/net/vpn-server/speed
10

[root@srv-rhsoft:~]$ cat /sys/class/net/vpn-client/speed
10
Comment 1 Laura Abbott 2016-09-23 15:25:38 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 2 Harald Reindl 2016-09-24 16:08:36 EDT
the same nonsense with a recent kernel on F24
yes the device was renamed but the same setup

[root@srv-rhsoft:~]$ cat /sys/class/net/vpn-server/speed
10

[root@srv-rhsoft:~]$ uname -a
Linux srv-rhsoft.rhsoft.net 4.7.4-200.fc24.x86_64 #1 SMP Thu Sep 15 18:42:09 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Harald Reindl 2016-09-24 16:10:38 EDT
vpn-server: tup 
vpn-client: tap

WAN-connection: 250 down / 25 up

[root@srv-rhsoft:~]$ cat /sys/class/net/vpn-server/speed
10

[root@srv-rhsoft:~]$ cat /sys/class/net/vpn-client/speed
10
Comment 4 Justin M. Forbes 2017-04-11 10:42:56 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-100.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.
Comment 5 Harald Reindl 2017-04-11 10:47:20 EDT
the same nonsense with Fedora 25 and Kernel 4.10.9-200.fc25.x86_64

[root@srv-rhsoft:~]$ cat /sys/class/net/vpn-client/speed
10
Comment 6 Justin M. Forbes 2017-04-11 11:03:42 EDT
Unfortunately, this is not so much a bug, as an upstream feature request. The current code does not check anything, it forces a value of 10 always.  I am closing this as upstream, and have linked the kernel bugzilla dealing with it.  Fedora will be happy to support this feature once it exists.

Note You need to log in before you can comment on or make changes to this bug.