Bug 1286997 - ship vdsm-hook-vmfex-dev with Vdsm
ship vdsm-hook-vmfex-dev with Vdsm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.2
: 3.6.2
Assigned To: Sagi Shnaidman
Michael Burman
: Improvement
Depends On:
Blocks: 1306132
  Show dependency treegraph
 
Reported: 2015-12-01 05:12 EST by Sagi Shnaidman
Modified: 2016-06-17 13:46 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this update, the vdsm-hook-vmfex-dev package is included with VDSM. Users can now connect their virtual machine network profiles to Cisco UCS-defined port profiles.
Story Points: ---
Clone Of:
: 1306132 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:46:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 154583 None None None 2016-06-17 13:46 EDT
oVirt gerrit 49566 master MERGED Include vmfex-dev-hook in vdsm install Never
oVirt gerrit 50270 ovirt-3.6 MERGED Add vmfex-dev hook to default RPMs for install Never
oVirt gerrit 50378 ovirt-3.6 MERGED Include vmfex-dev-hook in vdsm install Never

  None (edit)
Description Sagi Shnaidman 2015-12-01 05:12:01 EST
Require vmfex-dev hook installation for VDSM 3.6.
Comment 2 Nir Soffer 2015-12-09 04:42:18 EST
Why this hook should be required?

This hook is built with vdsm, and can be installed if needed.

If the functionality of this hook is always required, we should integrate this
hook in the networking code instead.
Comment 3 Sagi Shnaidman 2015-12-09 06:57:57 EST
Sorry, I have to redirect this question.
Comment 4 Dan Kenigsberg 2015-12-09 07:39:01 EST
vdsm-hook-vmfex-dev allows connecting oVirt VMs to UCS-defined port profiles, as explained in 

  http://www.ovirt.org/Features/UCS_Integration#Level_IV:_.22A_New_Hook.22

This functionality (connecting to VM-FEX) is repeatedly requested by customers. Since this hook is well tested and mature, shipping it with Vdsm is safe and useful.
Comment 7 Michael Burman 2015-12-24 09:41:13 EST
Verified on - vdsm-4.17.14-0.el7ev.noarch 
vdsm-hook-vmfex-dev-4.17.14-0.el7ev.noarch
Comment 9 errata-xmlrpc 2016-03-09 14:46:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html
Comment 10 Marina 2016-06-17 13:46:50 EDT
It seems to be a duplicated of this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=805884

Note You need to log in before you can comment on or make changes to this bug.