Bug 1287027 - glusterd: cli is showing command success for rebalance commands(command which uses op_sm framework) even though staging is failed in follower node.
glusterd: cli is showing command success for rebalance commands(command which...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Kaushal
: Triaged, ZStream
Depends On: 1285170
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 06:08 EST by Anand Nekkunti
Modified: 2016-06-16 09:47 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285170
Environment:
Last Closed: 2016-06-16 09:47:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-01 06:09:38 EST
REVIEW: http://review.gluster.org/12836 (glusterd/opsm: set global opinfo to dic whenever it's get modified) posted (#1) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 2 Vijay Bellur 2015-12-02 03:19:37 EST
REVIEW: http://review.gluster.org/12836 (glusterd/opsm: set global opinfo to dic whenever it's get modified) posted (#2) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 3 Vijay Bellur 2015-12-08 03:07:20 EST
REVIEW: http://review.gluster.org/12836 (glusterd: Maintain per transaction op-info object) posted (#3) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 4 Vijay Bellur 2015-12-08 15:13:43 EST
REVIEW: http://review.gluster.org/12836 (glusterd: Maintain per transaction op-info object) posted (#4) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 5 Vijay Bellur 2015-12-10 13:20:57 EST
COMMIT: http://review.gluster.org/12836 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 02168fdd1b0d63bac758db2f5e4a53b28e459f97
Author: anand <anekkunt@redhat.com>
Date:   Tue Dec 1 14:30:40 2015 +0530

    glusterd: Maintain per transaction op-info object
    
    Issues: Since in op-sm transactions a mix of access to global op-info & per transaction
    op-info objects are used, the correctness of op-info object may go for a toss resulting
    into incorrect response getting passed back to cli
    
    Fix: Use per transaction op-info object
    
    Change-Id: Ice023bace3e137dfd8e7b13bd5b53545a79a203f
    BUG: 1287027
    Signed-off-by: anand <anekkunt@redhat.com>
    Reviewed-on: http://review.gluster.org/12836
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:47:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.